it-swarm-ja.com

エラーを修正する方法「このアプリケーションを実行するには、最初に次のバージョンの.Net Frameworkのいずれかをインストールする必要があります:v2.0.50727」?

多くのアプリケーションでポップアップし始めたエラーを修正するにはどうすればよいですか?

このアプリケーションを実行するには、最初に次のバージョンの.Net Frameworkのいずれかをインストールする必要があります:v2.0.50727。

.NET Frameworkのインストールバージョンv2.0.50727を今すぐダウンロードしますか?

残念ながら、これは.NET 2.0ランタイムがすでにインストールされているため、インストールするほど簡単ではありません。 .NET2.0または.NET3.5 SP1の推奨インストーラーを実行すると、サイレントに終了します。

問題につながるイベント:

  • SQL Server 2008 R2をインストールしました。これは、SQL固有のプロジェクトのみを処理するVisual Studio2008のおもちゃバージョンをインストールします。
  • Visual Studio2008をアンインストールしました。
5
Contango

インストールされている.Netインストールの破損に関連して、これに似た状況をよく目にします。 .Netのアンインストールと再インストールに関するMartineauの提案は、おそらく正しい球場にあります。

エラーをスローするプログラムがインストールを検出しない場合は、.Netがインストールされたままの状態でこのエラーが発生する可能性があります。アンインストール/再インストールはそれを助けるでしょう。既存の.Netパッケージをアンインストールした後、MSからの最新のクリーンアップユーティリティについて、これを読むことができます 記事 。他のアプリケーションを削除するとシステム接続が破損したままになった場合は、システムを正常に戻すためにそのクリーンアップが必要になることがあります。

2
Sunny Molini

.net 4.0をインストールすると、以前は同様の問題が解決しました。理由はわかりません...

1

これが関連するWindowsのバージョンを指定すると役立ちます。

レジストリエントリ をチェックして、インストールされている.NETFrameworkのバージョンが破損していることを確認するためにアプリケーションが使用する必要がある値を確認できます。

.NET Framework 2.0をアンインストールできないバージョンのWindowsを使用している場合、この 記事 にいくつかの提案があります。

1
David Marshall