it-swarm-ja.com

PHPをPHP5.2にダウングレードしますか?

Ubuntu 11.04にPHP 5.2をインストールしたいのですが、それをうまく行うスクリプトがいくつかありましたが、Ubuntu 9でのみ、誰でもスクリプト/手順がありますか?

5
Amir Ashkenazi

最初の方法はAndpheのPPAを使用しています。この方法は here で説明されています。

  1. すべてのPHPパッケージをアンインストールします。
  2. Sudo apt-add-repository ppa:andphe/php && Sudo apt-get updateを実行してリポジトリを追加します
  3. Synapticを開きます。 [設定]-> [リポジトリ]に移動します。追加したばかりのリポジトリを選択し、「編集...」をクリックします。「natty」を「maverick」に置き換えます。 「OK」をクリックしてから「閉じる」をクリックします。
  4. リロードボタンをクリックします。
  5. Php5パッケージを見つけます。 Ctrl + Eを押します。PPAからバージョンを選択します。メインメニューで、[パッケージ]-> [バージョンのロック]をクリックします。
  6. 他のPHPパッケージに対してステップ5を繰り返します。
  7. 変更を適用します。

N.B。 「libapache2-mod-php5」、「php5-common」、「php5-cli」で始まり、残りは

2番目の方法は、Lucid用にビルドされたパッケージをインストールしようとしています。それらは here にあります。パッケージをダウンロードし、dpkg -iそれらをすべて、それから pin それらすべてをダウンロードします。最初の方法の方が良いと思うので、詳細には触れません。

3番目の方法はソースからインストールします。 このガイド はかなり良いようです。これがフォールバックルートです。

6
nickguletskii

PHPスクリプトがPHP 5.3で動作しない理由を試してみることをお勧めします。簡単に置き換えることができるいくつかの非推奨コードになっている可能性があります

PHPマニュアルには、5.2から5.3への移行に関するセクションがあります。 http://php.net/manual/en/migration53.php

1
Ian Pettitt

サーバーエディションを使用している場合:

  1. add AndpheのPPA

  2. 須藤apt-getアップデート

  3. Sudo apt-get install libapache2-mod-php5 = 5.2.14.dfsg.1-0ubuntu0〜andpheppa1

一般に=を使用すると、好みのバージョンをインストールできます。 apt-cache policyを使用して利用可能なバージョンを確認します。

/etc/apt/preferences.d/php5-5-2-14を作成することを忘れないでください

Package: php5-cli libapache2-mod-php5 php5-common
Pin: version 5.2*
Pin-Priority: 1001
0
lrkwz