it-swarm-ja.com

ia32-libs破損パッケージ(Ubuntu 12.04 x64)

Ubuntu 12.04 x64に最新のAndroid SDKがインストールされています EclipseとAndroid SDKの問題 とほぼ同じ問題があります。 Eclipse ADTプラグインが機能していないため、Androidウィンドウが表示されます

SDK/build-tools/17.0.0/aapt: error while loading shared libraries: libz.so.1: cannot open shared object file: No such file or directory

新しいAndroidプロジェクトを作成するとき。

それから私は試した

Sudo apt-get install ia32-libs

しかし、コマンドは失敗して戻ります

Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ia32-libs : Depends: ia32-libs-multiarch
E: Unable to correct problems, you have held broken packages.

これまで、私はこれに従いました answer 32ビットadbで機能し、これはUbuntuがia-32-libsを処理する方法に影響を与えた可能性があります。すべての32ビットAndroidツールを正しく実行するために必要なライブラリを正しくインストールするには、何をする必要がありますか?


update

この回答 を試しましたが、うまくいきませんでした。

Sudo apt-get purge libc6:i386 libncurses5:i386 libstdc++6:i386を試しました

しかし、ia32-libsはまだインストールされませんでした。


ldd ./aaptの出力

linux-gate.so.1 =>  (0xf778f000)
librt.so.1 => /lib32/librt.so.1 (0xf7768000)
libdl.so.2 => /lib32/libdl.so.2 (0xf7760000)
libpthread.so.0 => /lib32/libpthread.so.0 (0xf7740000)
libz.so.1 => not found
libstdc++.so.6 => /usr/lib32/libstdc++.so.6 (0xf7658000)
libm.so.6 => /lib32/libm.so.6 (0xf7628000)
libgcc_s.so.1 => /usr/lib32/libgcc_s.so.1 (0xf7608000)
libc.so.6 => /lib32/libc.so.6 (0xf7460000)
/lib/ld-linux.so.2 (0xf7790000)

libz.so.1が見つかりません。Ubuntuは zlib1g がすでに最新であると言っています。


これがうまくいったものです

Sudo apt-get install libgl1-mesa-dri:i386
Sudo apt-get install ia32-libs-multiarch:i386

Sudo apt-get install ia32-libs-multiarch

Sudo apt-get install ia32-libs
3
T. Webster

ubuntu 13.10では、ia32-libsパッケージはなくなりました。

Sudo apt-get install lib32z1 lib32ncurses5 lib32bz2-1.0
Sudo apt-get install libgl1-mesa-dri:i386

2番目は、すべての依存関係をインストールし、コンパイルの問題を解決します。依存関係は次のとおりです。

gcc-4.8-base:i386 libc6:i386 libdrm-intel1:i386 libdrm-nouveau2:i386 
libdrm-radeon1:i386 libdrm2:i386 libelf1:i386 libexpat1:i386 libffi6:i386
libgcc1:i386 libglapi-mesa:i386 libllvm3.3:i386 libpciaccess0:i386 
libstdc++6:i386 libtxc-dxtn-s2tc0:i386 zlib1g:i386

さようなら

E.

6
user221618

Sudo add-apt-repository ppa:gnome3-team/gnome3

Sudo apt-get update

Sudo apt-get install libcanberra-gtk-module

Sudo apt-get install ia32-libs

これと同じ問題がありました。これらのコマンドを実行する

4
chad

あなたのソリューションは私にとってはうまくいきませんでした。うまくいったのは、libcupsfilters1:i386の前にia32-libsをインストールすることでした。 launchpadのこのバグ のコメント#47でジョンが示唆したとおり。

しかし、この回避策はマシンにインストールされているi386ライブラリに依存するため、答えはユーザーに依存します。

乾杯。

0
evandromr

次のコマンドを実行すると、ia32-libs multiarchパッケージがインストールされます。

Sudo apt-get update
Sudo apt-get install ia32-libs-multiarch:i386
0
thefourtheye
Sudo apt-get install libgl1-mesa-dri:i386
Sudo apt-get install ia32-libs-multiarch:i386

Sudo apt-get install ia32-libs-multiarch

Sudo apt-get install ia32-libs
0
T. Webster