it-swarm-ja.com

未定義の変数:RecommendedVersionおよびRecommendedVersionEndOfSupport

「configuration.php」に入り、エラー報告を「最大」に変更しましたが、Joomla管理ページが突然白くなりました。

次に、バックエンドのログインページに移動すると、次のエラーメッセージが表示されます。

通知:未定義の変数:/home/mchardism/public_html/plugins/quickicon/phpversioncheck/phpversioncheck.phpの173行目

通知:未定義の変数:/home/mchardism/public_html/plugins/quickicon/phpversioncheck/phpversioncheck.phpの174行目のRecommendedVersionEndOfSupport

致命的なエラー:/home/mchardism/public_html/plugins/quickicon/phpversioncheck/phpversioncheck.phpの174行目のnullでメンバー関数format()を呼び出す

Phpversioncheck.phpの173行と174行に移動すると、次のようになります。

enter image description here

そして、これは私が行き詰まっているところです。問題を修正するためにこれらの行で何を変更する必要があるのか​​わかりません。私はこのphpversioncheck.phpファイルを開いたことがなく、なぜ突然問題が発生するのかわかりません。

私が使用しています:Joomla 3.6.5

3
Dave_M

@Sharkyは、私が同じ問題を解決するのに役立つ有効な点を示しました。ただし、この問題を解決するのが難しいと感じた他の人を助けるための代替手段を提供したいと思います。コード行をコメント化して他の何かを誤って壊すのではなく、

何らかの手段でデータベースにアクセスできる場合は、有効なフィールドビットを1から0に変更することで、mod_quickiconを無効にできます。

下の画像のように;

Sample record

このレコードは拡張機能テーブルにあります。

注:拡張機能テーブルに 'prefix'_extensionsがある場合があります

2
Omasan Esimaje

これは、古いPHPとJoomla!バージョンの組み合わせで発生する既知の問題です。将来的にはこれを回避するための対策が講じられており、3.9.14で修正が提供される予定です。

PHP、Joomla !、その拡張機能、および一般的にサーバーで実行されているすべてのソフトウェアを最新の状態に保つことをお勧めします。そうするつもりがない場合は、Quick Icon - PHP Version Checkプラグインを無効にする以外に方法はありません。

1
Sharky