it-swarm-ja.com

AWSAMIでTomcat8.5.16をTomcat8.0.46にダウングレードします

非互換性(Cookie関連)のため、AWSAMIでTomcat8.5.16をTomcat8.0.46にダウングレードしたいと思います。アマゾンはちょうど前日にそれを自動的に更新しました。

私は以下を試しましたが、成功しませんでした。

[[email protected] ec2-user]# Sudo yum downgrade Tomcat8

Loaded plugins: priorities, update-motd, upgrade-helper
36 packages excluded due to repository priority protections
Nothing to do

全体を元に戻したくない

yum history undo <id number>

別の選択肢はありますか?

ところで、私のマシンは次のとおりです。

[[email protected] ec2-user]# uname -a

Linux ip-xxxx 4.9.51-10.52.amzn1.x86_64 #1 SMP Fri Sep 29 01:16:19 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

ありがとう

2
JonyD

リリースノート に記載されているAmazon:

Known issues
Since we've moved from Tomcat 8 to Tomcat 8.5, there may be a few minor backwards incompatibilities.

私にとって小さな非互換性は、アプリにログインできなくなったことです。

彼らは戻るのをそれほど簡単にしません...しかし、あなたはそうすることができます。

Sudo vim /etc/yum.conf

この変更を行います。

#releasever=latest
releasever=2017.03

次に、yumを使用してダウングレードできます。

Sudo yum downgrade Tomcat8 Tomcat8-admin-webapps Tomcat8-lib Tomcat8-servlet-3.1-api Tomcat8-el-3.0-api Tomcat8-jsp-2.3-api

yumのやや冗長な出力は、何が起こるかを確認します。

...
---> Package Tomcat8.noarch 0:8.0.46-1.76.amzn1 will be a downgrade
---> Package Tomcat8.noarch 0:8.5.16-1.74.amzn1 will be erased
---> Package Tomcat8-admin-webapps.noarch 0:8.0.46-1.76.amzn1 will be a downgrade
---> Package Tomcat8-admin-webapps.noarch 0:8.5.16-1.74.amzn1 will be erased
---> Package Tomcat8-el-3.0-api.noarch 0:8.0.46-1.76.amzn1 will be a downgrade
---> Package Tomcat8-el-3.0-api.noarch 0:8.5.16-1.74.amzn1 will be erased
---> Package Tomcat8-jsp-2.3-api.noarch 0:8.0.46-1.76.amzn1 will be a downgrade
---> Package Tomcat8-jsp-2.3-api.noarch 0:8.5.16-1.74.amzn1 will be erased
---> Package Tomcat8-lib.noarch 0:8.0.46-1.76.amzn1 will be a downgrade
---> Package Tomcat8-lib.noarch 0:8.5.16-1.74.amzn1 will be erased
---> Package Tomcat8-servlet-3.1-api.noarch 0:8.0.46-1.76.amzn1 will be a downgrade
---> Package Tomcat8-servlet-3.1-api.noarch 0:8.5.16-1.74.amzn1 will be erased
...

幸せ。いつかTomcat8.5を楽しみにしています。だけど今日じゃない。

1
mdahlman