it-swarm-ja.com

Launchpad用UbuntuのGradle

Ubuntuには何らかの理由でGradleの新しいバージョンがリポジトリにないようです。 Launchpadでビルドされるプロジェクトに必要です。

これについてどうすればよいですか?

63
Marlinc

どうやらPPAをPPAへの依存関係として追加することが可能ですので、Gradleも含まれます。

https://help.launchpad.net/Packaging/PPA/BuildingASourcePackage#Dependencies

8
Marlinc

Gradleには、Java JDKをインストールする必要があります。 GradleにはJDK 1.5以降が必要です。 Gradleには独自のGroovyライブラリが付属しているため、Groovyをインストールする必要はありません。既存のGroovyインストールは、Gradleによって無視されます。

Gradleは、パスで見つかったJDKを使用します(確認するには、Java -versionを使用します)。または、目的のJDKのインストールディレクトリを指すようにJava_HOME環境変数を設定できます。

したがって、Java JDKがインストールされていることを確認してから、 GradleのWebサイト に進み、Gradleおよびその他必要な情報をダウンロードしてください。

または、押すだけ Ctrl+Alt+T キーボードでターミナルを開きます。開いたら、以下のコマンドを実行します:

Sudo add-apt-repository ppa:cwchien/gradle
Sudo apt-get update
Sudo apt-get install gradle

ソース:Gradle

86
Mitch
Sudo add-apt-repository ppa:cwchien/gradle
Sudo apt-get update

これは正しい答えですが、make Sudo apt-get install gradleの前に、次のことを行います。

Sudo apt-cache search gradle

次に、新しいリポジトリから最新バージョンをインストールします。私の場合、それ:

Sudo apt-get install gradle-1.9

できます! (必要なバージョンがわからない場合、メインリポジトリからgradle(1.4)がインストールされ、エラーが発生します...)。

30
Artem Zinoviev

gradlew、Gradle Wrapperが最良の方法であるようです: https://docs.gradle.org/2.11/userguide/gradle_wrapper .html

Gradleによって生成されたスクリプトで、自動的に次のことができます。

  • 不足している場合は、必要なGradleバージョンをダウンロードしてください
  • 必要なときに使用する

システムのgradleの代わりに、常にプロジェクトのルートからの./gradlew commandを使用します。

ラッパーを生成する方法は、ドキュメントと次の場所で説明されています: https://stackoverflow.com/questions/25769536/how-when-to-generate-gradle-wrapper-files

sdkman

私は最近、1つのプロジェクトだけにgradleが必要な同様の問題に直面しました:
aptを使用することはあまり魅力的ではありませんでした。また、私はかなり最近のgradleビルドが必要でした。

代わりに sdkman パッケージマネージャーを使用しました。これはJava開発に非常に適しています。
ubuntuシステム全体のセットアップに干渉することなく、ホームディレクトリに直接インストールされたパッケージの最新バージョンを入手できます。完了したら、タスク用に作成したユーザーを削除するだけで、すべてが以前のように戻ります。

Sdkmanとgradleをインストールするには:

$ curl -s "https://get.sdkman.io" | bash
Open new terminal  
$ sdk install gradle
1
lemonsqueeze