it-swarm-ja.com

予期されるエントリ 'main / binary-i386 / Packagesが見つかりません-Chrome

最近、いくつかのパッケージをインストールし、コマンドapt-get updateを使用しているときに、次のエラーに遭遇したことに気付きました。

Failed to fetch http://dl.google.com/linux/chrome/deb/dists/stable/Release  
Unable to find expected entry 'main/binary-i386/Packages' in Release file (Wrong sources.list entry or malformed file)

THIS Ask Ubuntuに関する最近の質問で述べたように、Chromeは32ビットシステムでサポートされなくなりますが、現在、libc6:i386libncurses5:i386libstdc++6:i386で64ビットUbuntu 14.04を実行しています32ビットアプリケーションサポート用にインストールされます。

前述のlibc6:i386libncurses5:i386libstdc++6:i386のインストールの結果、dpkgがi386パッケージを探しているため、このエラーが表示されますか?

このエラーを解決するにはどうすればよいですか?

EDIT-(他のスレッドで言及されているようにChromeを更新するだけではこの問題を解決できず、他の回答の情報は、私がこれを投稿した時点で存在していました)。

56
Kalamalka Kid
  1. 新しいターミナルウィンドウを開き、次のコマンドを実行します。

    Sudo gedit /etc/apt/sources.list.d/google-chrome.list
    
  2. 開いたテキストファイルでファイルを編集して、次の行を読み取ります。

    deb [Arch=AMD64] http://dl.google.com/linux/chrome/deb/ stable main
    

    必要な追加は、debの後、httpの前に[AMD64]アーキテクチャに入ることだけです。このファイル内の他のテキストを編集または置換しないでください。

  3. 保存をクリックします。 Geditウィンドウを閉じます。

    ターミナルに戻り、次を実行してパッケージリストを更新します。

    Sudo apt-get update
    

    「取得に失敗しました」APTエラーは表示されなくなります。

    上記の変更が失われないようにするには、上記で編集したファイルを生成する構成に[Arch=AMD64]を追加する必要があります。

  4. 次のコマンドを実行します。

    Sudo gedit  /opt/google/chrome/cron/google-chrome
    
  5. Debの検索を開くテキストファイルで、deb httpが次のようになるようにファイルをもう一度編集します。

    deb [Arch=AMD64] http
    

    このファイル内の他のテキストを編集または置換しないでください。

  6. 保存をクリックします。 Geditウィンドウを閉じます。

ソース:

103
Kalamalka Kid