it-swarm-ja.com

PPAから古いパッケージを取得する

特定のパッケージの古いバージョンをPPAからインストールできますか?具体的には、xorg-edgers ppaからxserver-xorg-video-intel(および依存関係)の古いバージョンを取得したいです。理由は、古いバージョンが私のハードウェアで動作するように思われたからです。現在のバージョンは、このパッケージの現在の安定版リリースと同様に、深刻なクラッシュを引き起こしているようです(実際にソースであるかどうかを確認したいと思います)。私は試した

apt-get install pkg=version

しかし、成功しませんでした。キャッシュ内のパッケージが後に失われるのではないかと心配しています

apt-get clean

以前のバージョンの正確なバージョン番号すら知りません。正確に1つ少なくする必要はないと仮定します。現在のバージョンはxserver-xorg-video-intel-2.20.15です。または、場所はありますか。ランチパッドで、以前のバージョンのパッケージを手動でダウンロードできますか?

9
highsciguy

はい、パッケージの特定のバージョンをapt-get install pkg=versionでインストールできますが、必要なバージョンはAPTソースの1つから入手できる必要があります。

例えば.

$ apt-cache policy dpkg
dpkg:
  Installed: 1.16.12
  Candidate: 1.16.12
  Version table:
     1.17.1 0
        800 http://localhost:3142/debian/ unstable/main AMD64 Packages
 *** 1.16.12 0
        900 http://localhost:3142/debian/ testing/main AMD64 Packages
        100 /var/lib/dpkg/status

この場合、1.17.11.16.12の両方がAPTで利用可能です。 1.16.12がインストールされています。

メインのUbuntuアーカイブと同様に、PPAは置き換えられたパッケージを削除します。そのため、PPAでは、Ubuntuリリースごとに1つのバージョンしか使用できません。

5
tumbleweed