it-swarm-ja.com

パッケージなし*利用可能。 yumからgitをインストールできません

Red Hat Enterprise Linux 6.5サーバーにgitをインストールしようとしていますが、壁にぶち当たりました。 yumを使用してgitのパッケージの依存関係を見つけることができません。

    [[email protected] mydir]# yum install curl-devel expat-devel gettext-devel \
    >   openssl-devel zlib-devel
    Loaded plugins: product-id, refresh-packagekit, security, subscription-manager
    This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
    Setting up Install Process
    No package curl-devel available.
    No package expat-devel available.
    No package gettext-devel available.
    No package openssl-devel available.
    No package zlib-devel available.
    Error: Nothing to do

フォーラムの投稿をいくつか読んだ後、EPELパッケージ here を見つけてインストールしました。

    [[email protected] mydir]# rpm -Uvh http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
    Retrieving http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
    warning: /var/tmp/rpm-tmp.IlnMHM: Header V3 RSA/SHA256 Signature, key ID 0608b895: NOKEY
    Preparing...                ########################################### [100%]
       1:epel-release           ########################################### [100%]

ただし、この後も同じエラーが発生します。誰かが私を助けてくれますか?

UPDATE:yum repolistの出力:

[[email protected] ~]# yum repolist
Loaded plugins: product-id, refresh-packagekit, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
repo id          repo name                                                status
epel             Extra Packages for Enterprise Linux 6 - x86_64           10,657
repolist: 10,657

UPDATE2:私は/i386//x86_64/に変更しました。これは、i386を消去してepel 64ビットリポジトリに置き換えたためです。

5
thenaglecode

RHNに登録していないようです。そのため、Redhatのベースリポジトリからダウンロードできません。

登録せずにRedhat公式パッケージを入手することはできません。

ない場合RHN credentials、代わりにCentosベースリポジトリを使用できます。詳細はこちら link をご覧ください。

3
cuonglm