it-swarm-ja.com

rpmでパッケージをインストールできないのはなぜですか? 「トランザクションロック」が表示される

yumに問題があり、再インストールしようとしています。ダウンロードしましたyum.3.2.0-40-el6.centos.noarch.rpm

私が試したとき:

$ rpm -ivh yum.3.2.0-40-el6.centos.noarch.rpm

私は得ます:

エラー:/var/lib/rpm/.rpm.lockにトランザクションロックを作成できません(権限が拒否されました)

実行してみましたsu -と私はこのエラーを受け取っています:

-bash:su:コマンドが見つかりません `

yumをアンインストールして依存関係を強制的に無視しようとすると、同じ「アクセス拒否エラー」が発生します(依存関係を無視することを強制せずに、いくつかの依存関係でアンインストールに失敗します)。

21
Brian Leach

このエラー:

エラー:/var/lib/rpm/.rpm.lockにトランザクションロックを作成できません(権限が拒否されました)

...は、root以外のユーザーとしてrpm -ivh ...コマンドを実行しようとしているように見えます。

次のように実行する必要があります。

$ Sudo rpm -ivh yum.3.2.0-40-el6.centos.noarch.rpm

また、yum..rpmファイルをダウンロードしたディレクトリにいることを確認してください。おそらく、通常のユーザー名でダウンロードして、ルートとしてインストールしようとしている可能性があります。ルートになると、通常はディレクトリが/rootに変更されます。

su -が何らかの理由で壊れた場合は、次のようにrootになることもできます。

$ Sudo -i
18
slm

$ Sudo rm /var/lib/rpm/.rpm.lockを実行してみてください

0
Vinay Vemula

前にSudo suを実行すると、動作します:)

0
Tom Roggero