it-swarm-ja.com

curl --tlsv1と--tlsv1.0に違いはありますか?

Curlのマニュアルページには_-1 --tlsv1_がリストされており、v1.1およびv1.2とともに_--tlsv1.0_が個別にリストされています。

説明は次のとおりです。

-1, --tlsv1 (SSL) Forces curl to use TLS version 1 when negotiating with a remote TLS server.

以降:

--tlsv1.0 (SSL) Forces curl to use TLS version 1.0 when negotiating with a remote TLS server. (Added in 7.34.0)

これらのtlsv1オプションとtlsv1.0オプションに違いはありますか?

1
greggles

githubのcurlヘルプコード を見ると、

-1、-tlsv1使用> = TLSv1(SSL)

--tlsv1.0 TLSv1.0(SSL)を使用

--tlsv1.1 TLSv1.1(SSL)を使用

--tlsv1.2 TLSv1.2(SSL)を使用

したがって、-tlsv1は1.0、1.1、または1.2のいずれかを使用し、他の3つは特定のものを使用します。

セキュリティを強化するには、特に--tlsv1.2を使用します。

1