it-swarm-ja.com

「値 'stable'はAPT :: Default-Releaseでは無効です」というエラーを修正するにはどうすればよいですか?

Debian Squeeze(安定版)からWheezy(テスト版)へのアップグレード後、Synapticは次のエラーで失敗します:

E: The value 'stable' is invalid for APT::Default-Release as such a release is not available in the sources
E: _cache->open() failed, please report.

ただし、この値は/etcのどこにも設定されていません。このエラーを修正するにはどうすればよいですか?

7
thejh

/root/.synaptic/synaptic.confをご覧ください。 DefaultDistro行を探して、その値を変更します。 stablewheezyに置き換えます。

6
thejh

Aptでも同じエラーが発生するため、シナプスとは無関係です。ただし、この構成は存在します:

# grep -ri stable /etc
/etc/apt.conf.d/99myDefaultRelease:APT::Default-Release "stable";

したがって、そのファイルを「jessie」に変更すると、私の場合は修正されます(jessieを使用しているため)。

6
math