it-swarm-ja.com

Debianバスターをi386からAMD64にクロスグレードする

https://wiki.debian.org/CrossGrading の指示に従いましたが、dpkg、tarをクロスグレードした後、aptはすべて完全に壊れます。例:apt upgrade

# LANG=C apt upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 console-common : Depends: kbd but it is not installed
 debconf : PreDepends: Perl-base (>= 5.20.1-3~) but it is not installed
           Recommends: apt-utils (>= 0.5.1) but it is not installed
 debconf-i18n : Depends: liblocale-gettext-Perl but it is not installed
                Depends: libtext-iconv-Perl but it is not installed
                Depends: libtext-charwidth-Perl but it is not installed
 default-mysql-client : Depends: mariadb-client-10.3 but it is not installed
 default-mysql-server : Depends: mariadb-server-10.3 but it is not installed
 dhcp3-client : Depends: isc-dhcp-client but it is not installed
 dhcp3-common : Depends: isc-dhcp-common but it is not installed
 diff : PreDepends: diffutils but it is not installed
 Host : Depends: bind9-Host but it is not installed
 init-system-helpers : Depends: Perl-base (>= 5.20.1-3) but it is not installed
 krb5-config : Depends: bind9-Host but it is not installed
 libalgorithm-c3-Perl : Depends: Perl but it is not installed
 libapache-session-Perl : Depends: Perl but it is not installed
                          Recommends: libdbi-Perl but it is not installed
 libapache2-mod-Perl2:i386 : Depends: libdevel-symdump-Perl:i386 but it is not installable
                             Recommends: libapache2-reload-Perl:i386 but it is not installable
 libapache2-reload-Perl : Depends: Perl but it is not installed
                          Depends: libapache2-mod-Perl2 but it is not installed
 libapache2-svn : Depends: libapache2-mod-svn but it is not installed
 libappconfig-Perl : Depends: Perl but it is not installed
 libauthen-radius-Perl : Depends: Perl but it is not installed
 libauthen-sasl-Perl : Depends: Perl but it is not installed
 libb-hooks-endofscope-Perl : Depends: Perl but it is not installed
                              Depends: libvariable-magic-Perl but it is not installed
 libbind-confparser-Perl : Depends: Perl but it is not installed
 libbit-vector-Perl:i386 : Depends: libcarp-clan-Perl:i386 but it is not installable
 libcache-cache-Perl : Depends: libipc-sharelite-Perl but it is not installed
                       Depends: Perl but it is not installed
 libcarp-assert-Perl : Depends: Perl but it is not installed
 libcarp-clan-Perl : Depends: Perl but it is not installed
 libcgi-fast-Perl : Depends: Perl but it is not installed
                    Depends: libfcgi-Perl but it is not installed
 libcgi-pm-Perl : Depends: Perl but it is not installed
                  Depends: libhtml-parser-Perl but it is not installed
 libclass-accessor-Perl : Depends: Perl but it is not installed
                          Depends: libsub-name-Perl but it is not installed
 libclass-c3-Perl : Depends: Perl but it is not installed
                    Recommends: libclass-c3-xs-Perl but it is not installed
 libclass-container-Perl : Depends: Perl but it is not installed
                           Depends: libparams-validate-Perl but it is not installed
 libclass-data-inheritable-Perl : Depends: Perl but it is not installed
 libclass-dbi-abstractsearch-Perl : Depends: Perl but it is not installed
 libclass-dbi-Perl : Depends: libclone-Perl but it is not installed
                     Depends: Perl but it is not installed
 libclass-inspector-Perl : Depends: Perl but it is not installed
 libclass-makemethods-Perl : Depends: Perl but it is not installed
 libclass-method-modifiers-Perl : Depends: Perl but it is not installed
 libclass-trigger-Perl : Depends: Perl but it is not installed
 libclone-choose-Perl : Depends: Perl but it is not installed
                        Recommends: libclone-Perl but it is not installed or
                                    libclone-pp-Perl but it is not installed
 libconfig-inifiles-Perl : Depends: Perl (>= 5.19.5) but it is not installed or
                                    libscalar-list-utils-Perl (>= 1:1.33)
 libconvert-binhex-Perl : Depends: Perl but it is not installed
 libcpan-changes-Perl : Depends: Perl but it is not installed
 libcrypt-rc4-Perl : Depends: Perl but it is not installed
 libdata-dump-Perl : Depends: Perl but it is not installed
 libdata-optlist-Perl : Depends: Perl but it is not installed
                        Depends: libparams-util-Perl but it is not installed
 libdata-Perl-perl : Depends: Perl but it is not installed
                     Depends: liblist-moreutils-Perl but it is not installed
 libdate-calc-Perl : Depends: Perl but it is not installed
                     Depends: libbit-vector-Perl (>= 7.4) but it is not installed
                     Recommends: libdate-calc-xs-Perl but it is not installed
 libdate-manip-Perl : Depends: Perl but it is not installed
 libdbix-contextualfetch-Perl : Depends: Perl but it is not installed
                                Depends: libdbi-Perl but it is not installed
 libdbix-datasource-Perl : Depends: Perl but it is not installed
                           Depends: libdbi-Perl but it is not installed
 libdevel-callchecker-Perl:i386 : Depends: libdynaloader-functions-Perl:i386 but it is not installable
 libdevel-globaldestruction-Perl : Depends: Perl (>= 5.14.0) but it is not installed
 libdevel-stacktrace-Perl : Depends: Perl but it is not installed
 libdevel-symdump-Perl : Depends: Perl but it is not installed
 libdigest-bubblebabble-Perl : Depends: Perl but it is not installed
 libdigest-hmac-Perl : Depends: Perl but it is not installed
 libdigest-Perl-md5-Perl : Depends: Perl but it is not installed
 libdynaloader-functions-Perl : Depends: Perl but it is not installed
 libencode-locale-Perl : Depends: Perl but it is not installed
 liberror-Perl : Depends: Perl but it is not installed
 libexception-class-Perl : Depends: Perl but it is not installed
 libexporter-tiny-Perl : Depends: Perl but it is not installed
 libfile-listing-Perl : Depends: Perl but it is not installed
 libfile-sharedir-Perl : Depends: Perl but it is not installed
 libfile-Slurp-Perl : Depends: Perl but it is not installed
 libgetopt-long-descriptive-Perl : Depends: Perl but it is not installed
                                   Depends: libparams-validate-Perl but it is not installed
 libgraph-Perl : Depends: Perl but it is not installed
 libgraphviz-Perl : Depends: Perl but it is not installed
 libhash-merge-Perl : Depends: Perl but it is not installed
 libhtml-mason-Perl : Depends: Perl but it is not installed
                      Depends: libhtml-parser-Perl but it is not installed
                      Depends: libparams-validate-Perl but it is not installed
                      Recommends: libapache2-mod-Perl2 but it is not installed
 libhtml-parser-Perl:i386 : Depends: libhtml-tagset-Perl:i386 but it is not installable
                            Recommends: libhttp-message-Perl:i386 but it is not installable
 libhtml-tagset-Perl : Depends: Perl but it is not installed
 libhtml-template-Perl : Depends: Perl but it is not installed
 libhtml-tree-Perl : Depends: Perl but it is not installed
                     Depends: libhtml-parser-Perl but it is not installed
                     Recommends: libhtml-format-Perl but it is not installed
 libhttp-cookies-Perl : Depends: Perl but it is not installed
 libhttp-date-Perl : Depends: Perl but it is not installed
 libhttp-message-Perl : Depends: Perl but it is not installed
 libhttp-negotiate-Perl : Depends: Perl but it is not installed
 libima-dbi-Perl : Depends: Perl but it is not installed
                   Depends: libdbi-Perl but it is not installed
 libimport-into-Perl : Depends: Perl but it is not installed
 libio-html-Perl : Depends: Perl but it is not installed
 libio-socket-inet6-Perl : Depends: Perl but it is not installed
                           Depends: libsocket6-Perl but it is not installed
 libio-socket-ssl-Perl : Depends: libnet-ssleay-Perl (>= 1.85-2~) but it is not installed
                         Depends: libssl1.1 (>= 1.1.1) but it is not installed
                         Depends: Perl but it is not installed
                         Recommends: Perl (>= 5.15.6) but it is not installed or
                                     libsocket-Perl or
                                     libsocket6-Perl but it is not installed
 libio-string-Perl : Depends: Perl but it is not installed
 libio-stringy-Perl : Depends: Perl but it is not installed
 libipc-run-Perl : Depends: Perl but it is not installed
                   Depends: libio-pty-Perl but it is not installed
 liblingua-en-inflect-Perl : Depends: Perl but it is not installed
 liblist-moreutils-Perl:i386 : Depends: libexporter-tiny-Perl:i386 but it is not installable
 liblog-any-Perl : Depends: Perl but it is not installed
 liblua5.1-sec-dev : Depends: lua-sec but it is not installed
 liblua5.1-sec1 : Depends: lua-sec but it is not installed
 liblwp-mediatypes-Perl : Depends: Perl but it is not installed
 liblwp-protocol-https-Perl : Depends: Perl but it is not installed
 libmailtools-Perl : Depends: Perl but it is not installed
 libmath-base-convert-Perl : Depends: Perl but it is not installed
 libmd5-Perl : Depends: Perl (>= 5.8.0-10) but it is not installed
 libmime-base32-Perl : Depends: Perl but it is not installed
 libmime-tools-Perl : Depends: Perl but it is not installed
 libmodule-build-Perl : Depends: Perl but it is not installed
                        Depends: Perl (>= 5.19.5) but it is not installed or
                                 libtest-harness-Perl (>= 3.29)
                        Depends: Perl (>= 5.21.3) but it is not installed or
                                 libcpan-meta-Perl (>= 2.142060)
                        Recommends: libmodule-signature-Perl but it is not installed
                        Recommends: libsoftware-license-Perl (>= 0.103009) but it is not installed
 libmodule-implementation-Perl : Depends: Perl but it is not installed
 libmodule-runtime-Perl : Depends: Perl but it is not installed
                          Depends: libparams-classify-Perl but it is not installed
 libmoo-Perl : Depends: Perl but it is not installed
               Recommends: libclass-xsaccessor-Perl (>= 1.18) but it is not installed
               Recommends: libsub-name-Perl (>= 0.08) but it is not installed
 libmoox-handlesvia-Perl : Depends: Perl but it is not installed
 libmro-compat-Perl : Depends: Perl but it is not installed
                      Recommends: libclass-c3-xs-Perl but it is not installed
 libnamespace-autoclean-Perl : Depends: libsub-identify-Perl but it is not installed
                               Depends: Perl but it is not installed
 libnamespace-clean-Perl : Depends: libsub-identify-Perl but it is not installed
                           Depends: libsub-name-Perl but it is not installed
                           Depends: Perl but it is not installed
 libnet-daemon-Perl : Depends: Perl but it is not installed
 libnet-dns-Perl : Depends: Perl but it is not installed
                   Recommends: libnet-dns-sec-Perl but it is not installed
                   Recommends: libnet-libidn-Perl but it is not installed
 libnet-dns-sec-Perl:i386 : Depends: libnet-dns-Perl:i386 (>= 1.08) but it is not installable
 libnet-http-Perl : Depends: Perl but it is not installed
                    Depends: Perl (>= 5.19.8) but it is not installed or
                             libio-socket-ip-Perl (>= 0.26)
 libnet-ip-Perl : Depends: Perl but it is not installed
 libnet-smtp-ssl-Perl : Depends: Perl but it is not installed
 libole-storage-lite-Perl : Depends: Perl but it is not installed
 libpackage-stash-Perl : Depends: Perl but it is not installed
                         Recommends: libpackage-stash-xs-Perl but it is not installed
 libpackage-variant-Perl : Depends: Perl but it is not installed
 libpam-krb5:i386 : Depends: krb5-config:i386 but it is not installable
 libpam-runtime : Depends: libpam-modules (>= 1.0.1-6) but it is not installed
 libparallel-forkmanager-Perl : Depends: Perl but it is not installed
 libparams-validate-Perl:i386 : Depends: libmodule-implementation-Perl:i386 but it is not installable
 libparse-debianchangelog-Perl : Depends: Perl but it is not installed
                                 Depends: liblocale-gettext-Perl but it is not installed
 libparse-recdescent-Perl : Depends: Perl but it is not installed
 libpath-tiny-Perl : Depends: Perl but it is not installed
                     Recommends: libunicode-utf8-Perl but it is not installed
 libplrpc-Perl : Depends: Perl (>= 5.6.0-16) but it is not installed
                 Depends: libstorable-Perl or
                          Perl-modules (>= 5.8.0-10)
 libpod-markdown-Perl : Depends: Perl but it is not installed
                        Depends: Perl (>= 5.18.0) but it is not installed or
                                 libpod-simple-Perl (>= 3.27)
                        Recommends: libhtml-parser-Perl but it is not installed
 libpod-readme-Perl : Depends: Perl but it is not installed
                      Depends: Perl (>= 5.19.5) but it is not installed or
                               libscalar-list-utils-Perl (>= 1:1.33)
                      Recommends: libtype-tiny-xs-Perl but it is not installed
 libreadonly-Perl : Depends: Perl but it is not installed
 libref-util-Perl : Depends: Perl but it is not installed
                    Recommends: libref-util-xs-Perl but it is not installed
 librole-tiny-Perl : Depends: Perl but it is not installed
 libsnmp-info-Perl : Depends: Perl but it is not installed
                     Depends: libnetaddr-ip-Perl but it is not installed
                     Depends: libsnmp-Perl but it is not installed
 libspreadsheet-parseexcel-Perl : Depends: Perl but it is not installed
                                  Depends: libjcode-pm-Perl but it is not installed
                                  Depends: libunicode-map-Perl but it is not installed
 libspreadsheet-writeexcel-Perl : Depends: Perl but it is not installed
 libsql-abstract-limit-Perl : Depends: Perl but it is not installed
                              Depends: libdbi-Perl but it is not installed
 libsql-abstract-Perl : Depends: Perl but it is not installed
 libsql-statement-Perl : Depends: Perl but it is not installed
                         Depends: libclone-Perl but it is not installed
                         Depends: libparams-util-Perl but it is not installed
                         Recommends: libdbi-Perl but it is not installed
                         Recommends: libtext-soundex-Perl but it is not installed or
                                     Perl (< 5.17.9) but it is not installed
 libsql-translator-Perl : Depends: Perl but it is not installed
                          Depends: libdbi-Perl but it is not installed
                          Recommends: libgd-Perl but it is not installed
                          Recommends: libjson-Perl but it is not installed
                          Recommends: libtemplate-Perl but it is not installed
                          Recommends: libxml-libxml-Perl but it is not installed
                          Recommends: libyaml-Perl but it is not installed
 libstrictures-Perl : Depends: Perl but it is not installed
 libsub-exporter-Perl : Depends: Perl but it is not installed
 libsub-exporter-progressive-Perl : Depends: Perl but it is not installed
 libsub-install-Perl : Depends: Perl but it is not installed
 libsub-quote-Perl : Depends: Perl but it is not installed
 libswitch-Perl : Depends: Perl but it is not installed
 libtemplate-Perl:i386 : Depends: libappconfig-Perl:i386 (>= 1.56) but it is not installable
 libtext-autoformat-Perl : Depends: Perl but it is not installed
 libtext-recordparser-Perl : Depends: liblist-moreutils-Perl but it is not installed
                             Depends: Perl but it is not installed
 libtext-reform-Perl : Depends: Perl but it is not installed
 libtext-tabulardisplay-Perl : Depends: Perl but it is not installed
 libtext-wrapi18n-Perl : Depends: libtext-charwidth-Perl but it is not installed
 libtie-ixhash-Perl : Depends: Perl but it is not installed
 libtimedate-Perl : Depends: Perl but it is not installed
 libtry-tiny-Perl : Depends: Perl but it is not installed
 libtype-tiny-Perl : Depends: Perl but it is not installed
                     Recommends: libscalar-list-utils-Perl (>= 1:1.40)
                     Recommends: libtype-tiny-xs-Perl but it is not installed
 libuniversal-moniker-Perl : Depends: Perl but it is not installed
 libwww-Perl : Depends: Perl but it is not installed
               Depends: libhtml-parser-Perl but it is not installed
               Recommends: libhtml-form-Perl but it is not installed
               Recommends: libhtml-format-Perl but it is not installed
               Recommends: libhttp-daemon-Perl but it is not installed
 libwww-robotrules-Perl : Depends: Perl but it is not installed
 libxml-libxml-Perl:i386 : Depends: libxml-namespacesupport-Perl:i386 but it is not installable
                           Depends: libxml-sax-Perl:i386 but it is not installable
 libxml-namespacesupport-Perl : Depends: Perl but it is not installed
 libxml-sax-base-Perl : Depends: Perl but it is not installed
 libxml-sax-expat-Perl : Depends: Perl but it is not installed
                         Depends: libxml-parser-Perl but it is not installed
 libxml-sax-Perl : Depends: Perl but it is not installed
 libxml-simple-Perl : Depends: Perl but it is not installed
 libxml-twig-Perl : Depends: Perl but it is not installed
                    Depends: libxml-parser-Perl but it is not installed
                    Recommends: libtext-iconv-Perl but it is not installed
                    Recommends: libhtml-parser-Perl but it is not installed
 libxml-writer-Perl : Depends: Perl but it is not installed
 libxml-xpath-Perl : Depends: Perl but it is not installed
                     Depends: libxml-parser-Perl but it is not installed
                     Depends: libscalar-list-utils-Perl
 mailx : Depends: bsd-mailx but it is not installed
 mariadb-client-10.3:i386 : Depends: libconfig-inifiles-Perl:i386 but it is not installable
 mediawiki : Depends: Apache2 but it is not installed or
                      httpd
             Recommends: php-apcu but it is not installed
             Recommends: php-wikidiff2 but it is not installed
             Recommends: python3 but it is not installed
 mediawiki-extensions-math : Depends: mediawiki-math-texvc (>= 2:1.0) but it is not installable
                             Recommends: mediawiki-extensions-base but it is not installable
 mediawiki-math:i386 : Depends: mediawiki-extensions-math:i386 but it is not installable
 Mercurial:i386 : Depends: Mercurial-common:i386 (= 4.8.2-1+deb10u1) but it is not installable
 mysql-client:i386 : Depends: default-mysql-client:i386 but it is not installable
 nagios-plugins-basic : Depends: monitoring-plugins-basic but it is not installed
 openssl-blacklist : Depends: python but it is not installed
 Perl-modules-5.24 : Depends: Perl-base (>= 5.24.1-1) but it is not installed
                     Recommends: Perl (>= 5.24.1-1) but it is not installed
 Perl-modules-5.28 : Depends: Perl-base (>= 5.28.1-1) but it is not installed
                     Recommends: Perl (>= 5.28.1-1) but it is not installed
 php-apcu:i386 : PreDepends: php-common:i386 (>= 2:69~) but it is not installable
 php-apcu-bc:i386 : PreDepends: php-common:i386 (>= 2:69~) but it is not installable
 php-bz2 : Depends: php7.3-bz2 but it is not installed
 php-cli : Depends: php7.3-cli but it is not installed
 php-curl : Depends: php7.3-curl but it is not installed
 php-Gd : Depends: php7.3-Gd but it is not installed
 php-intl : Depends: php7.3-intl but it is not installed
 php-mbstring : Depends: php7.3-mbstring but it is not installed
 php-mysql : Depends: php7.3-mysql but it is not installed
 php-soap : Depends: php7.3-soap but it is not installed
 php-wikidiff2:i386 : Depends: php-common:i386 (>= 1:7.0+33~) but it is not installable
 php-xml : Depends: php7.3-xml but it is not installed
 php-Zip : Depends: php7.3-Zip but it is not installed
 php5 : Depends: libapache2-mod-php5 (>= 5.6.40+dfsg-0+deb8u9~) but it is not installable or
                 libapache2-mod-php5filter (>= 5.6.40+dfsg-0+deb8u9~) but it is not installable or
                 php5-cgi (>= 5.6.40+dfsg-0+deb8u9~) but it is not installable or
                 php5-fpm (>= 5.6.40+dfsg-0+deb8u9~) but it is not installable
        Depends: php5-common (>= 5.6.40+dfsg-0+deb8u9~) but it is not installable
 php7.0-bz2:i386 : Depends: php-common:i386 (>= 1:35) but it is not installable
 php7.0-common:i386 : Depends: php-common:i386 (>= 1:35) but it is not installable
 php7.0-Gd:i386 : Depends: php-common:i386 (>= 1:35) but it is not installable
 php7.0-intl:i386 : Depends: php-common:i386 (>= 1:35) but it is not installable
 php7.0-json:i386 : Depends: php-common:i386 (>= 1:35) but it is not installable
 php7.0-mbstring:i386 : Depends: php-common:i386 (>= 1:35) but it is not installable
 php7.0-mysql:i386 : Depends: php-common:i386 (>= 1:35) but it is not installable
 php7.0-opcache:i386 : Depends: php-common:i386 (>= 1:35) but it is not installable
 php7.0-readline:i386 : Depends: php-common:i386 (>= 1:35) but it is not installable
 php7.0-soap:i386 : Depends: php-common:i386 (>= 1:35) but it is not installable
 php7.0-xml:i386 : Depends: php-common:i386 (>= 1:35) but it is not installable
 php7.0-Zip:i386 : Depends: php-common:i386 (>= 1:35) but it is not installable
 php7.3 : Depends: libapache2-mod-php7.3 but it is not installed or
                   php7.3-fpm but it is not installed or
                   php7.3-cgi but it is not installed
          Depends: php7.3-common but it is not installed
 php7.3-bz2:i386 : Depends: php-common:i386 (>= 1:35) but it is not installable
 php7.3-common:i386 : Depends: php-common:i386 (>= 1:35) but it is not installable
 php7.3-curl:i386 : Depends: php-common:i386 (>= 1:35) but it is not installable
 php7.3-Gd:i386 : Depends: php-common:i386 (>= 1:35) but it is not installable
 php7.3-intl:i386 : Depends: php-common:i386 (>= 1:35) but it is not installable
 php7.3-json:i386 : Depends: php-common:i386 (>= 1:35) but it is not installable
 php7.3-mbstring:i386 : Depends: php-common:i386 (>= 1:35) but it is not installable
 php7.3-mysql:i386 : Depends: php-common:i386 (>= 1:35) but it is not installable
 php7.3-opcache:i386 : Depends: php-common:i386 (>= 1:35) but it is not installable
 php7.3-readline:i386 : Depends: php-common:i386 (>= 1:35) but it is not installable
 php7.3-soap:i386 : Depends: php-common:i386 (>= 1:35) but it is not installable
 php7.3-xml:i386 : Depends: php-common:i386 (>= 1:35) but it is not installable
 php7.3-Zip:i386 : Depends: php-common:i386 (>= 1:35) but it is not installable
 phpmyadmin : Depends: php-json
              Depends: Perl but it is not installed
              Recommends: Apache2 but it is not installed or
                          lighttpd but it is not installed or
                          httpd
 pure-ftpd-common : Depends: libpam-modules but it is not installed
                    Depends: Perl but it is not installed
                    Recommends: pure-ftpd
 pure-ftpd-ldap:i386 : Depends: pure-ftpd-common:i386 (= 1.0.47-3) but it is not installable
 python-certifi : Depends: python (< 2.8) but it is not installed
                  Depends: python (>= 2.7) but it is not installed
 python-cryptography:i386 : Depends: python-asn1crypto:i386 but it is not installable
                            Depends: python-enum34:i386 but it is not installable
                            Depends: python-ipaddress:i386 but it is not installable
 python-openssl : Depends: python-cryptography (>= 2.3) but it is not installed
 python3-acme : Depends: python3-cryptography (>= 1.2.3) but it is not installed
 python3-certbot : Depends: python3-cryptography (>= 1.2.3) but it is not installed
                   Depends: python3-zope.interface but it is not installed
 python3-cryptography:i386 : Depends: python3-asn1crypto:i386 (>= 0.21.0~) but it is not installable
 python3-distutils : Depends: python3 (>= 3.7.1-1~) but it is not installed
                     Depends: python3 (< 3.8) but it is not installed
 python3-josepy : Depends: python3-cryptography (>= 0.8) but it is not installed
 python3-lib2to3 : Depends: python3 (>= 3.7.1-1~) but it is not installed
                   Depends: python3 (< 3.8) but it is not installed
 python3-openssl : Depends: python3-cryptography (>= 2.3) but it is not installed
 python3-zope.component : Depends: python3-zope.hookable but it is not installed
                          Depends: python3-zope.interface (>= 4.1.0) but it is not installed
 sasl2-bin:i386 : Depends: db-util:i386 but it is not installable
 sendmail-base : Depends: make
 stunnel : Depends: stunnel4 (>= 3:4.20-3) but it is not installed
 sysv-rc : Depends: insserv (> 1.12.0-10) but it is not installed
 update-inetd : Depends: Perl but it is not installed
 z-Push-config-Apache : Depends: Apache2 but it is not installed
                        Depends: libapache2-mod-php or
                                 libapache2-mod-php5 but it is not installable
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

apt --fix-broken installを実行すると、システムが完全に壊れ、apt/dpkgが削除されます。

Sources.listは見栄えが悪いように見えます(ローカルのおおよそのインスタンスを指しています):

deb http://apt-proxy:9999/debian buster main contrib non-free
deb http://apt-proxy:9999/security buster/updates main contrib non-free
deb http://packages.prosody.im/debian stable main
deb http://ftp.at.debian.org/debian buster-backports main
# z-Push
deb http://repo.z-hub.io/z-Push:/final/Debian_8.0/ /

参考までに、apt-config dumpの出力はかなり大きいので、Pastebinに置きました: https://paste.ubuntu.com/p/HxTV7jkvws/

システムはDebianバスター(さまざまなバージョンからアップグレード)であり、VM /コンテナー(現在はlxc)です。絶対に再インストールは避けたいです。

どうすれば続行できますか?

(ZFSスナップショットがあるので、クリーンリスタートも実行できます)

1
divB

アプリケーションまたはオペレーティングシステムを32ビットから64ビットに変換するには、アプリケーションをアンインストールして対応する64ビットアプリケーションをインストールする必要があります。オペレーティングシステム全体を64ビットに変換するには、すべてをバックアップして再インストールする必要があります。オペレーティングシステム。 64ビットへの変換は更新に耐えられる以上のものであるため、これは常に当てはまります。

1
John