it-swarm-ja.com

DebianJessie問題に関するNVIDIA独自のドライバー

私は以前にDebianサーバーの実行に手を出しましたが、メインPCにそのグラフィカルインターフェイスを使用するのはこれが初めてです。私はnvidia独自のドライバーをインストールしようとしています。私はSLIgtx 460s1GBを持っています。 Debian "Jessie"を実行しています(問題がテストビルドの実行が原因であることが判明した場合は、お知らせください)。

これまでのところ、Debianの正確な指示に従うことを試みました wiki

再起動すると、デスクトップ環境が起動すると(ログイン画面も表示されません)、プライマリモニターは完全に空白のままになりますが、モニターが信号がないことを通知しないため、何らかのビデオ信号を受信して​​います。これは、信号がまったく与えられていない私のセカンダリモニターとは対照的です。奇妙なことに、HDMI経由でモニターをマザーボードの統合グラフィックスに接続すると、左上隅にカーソルが点滅している黒い画面が表示されます。 alt + ctrl + F1でターミナルにログインし、システムからnvidiaパッケージを削除し、xorg構成ファイルを削除して、再起動することができます。これにより、nouveau、デュアルモニター、その他すべてを使用して、システムが使用可能な状態に戻ります。

'nvidia-driver'メタパッケージをインストールするなど、少し異なる方法を試しました。それでも、同じ結果が得られます。

Xorgログを調べてみると、次のセグメントが見つかりました。

[     7.605] (II) LoadModule: "glx"
[     7.605] (II) Loading /usr/lib/xorg/modules/linux/libglx.so
[     7.642] (II) Module glx: vendor="NVIDIA Corporation"
[     7.642]    compiled for 4.0.2, module version = 1.0.0
[     7.642]    Module class: X.Org Server Extension
[     7.642] (II) NVIDIA GLX Module  331.67  Fri Apr  4 11:43:47 PDT 2014
[     7.642] Loading extension GLX
[     7.642] (II) LoadModule: "nvidia"
[     7.642] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[     7.649] (II) Module nvidia: vendor="NVIDIA Corporation"
[     7.649]    compiled for 4.0.2, module version = 1.0.0
[     7.649]    Module class: X.Org Video Driver
[     7.650] (II) NVIDIA dlloader X Driver  331.67  Fri Apr  4 11:24:40 PDT 2014
[     7.650] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[     7.650] (++) using VT number 7

どんな助けでも大歓迎です。必要な情報があれば喜んで提供します。ありがとう。

2
djogorchock

あなたが説明することは、nvidiaカードと独自のドライバー(debian wheezyとjessie)を備えたユーザーPCをインストールするときによくある問題と非常によく似ています-私は通常、次の手順と添付のxorg.confファイルを使用してそれを解決できます(I Debian wikiサイトからのものを一度試したことを覚えていますが、何かが間違っていたに違いありません。そうでなければ、私はまだそれを使用します)。

Ctrl+Alt+F1 ターミナル:

/etc/init.d/lightdm stop
apt-get install nvidia-driver
apt-get clean
depmod -amodprobe -r nvidia
apt-get update
apt-get upgrade
modprobe nvidia

これらの手順の後、次のxorg.confをUSBスティックまたはネットワークの場所からコピーし、lightdmを再起動します。

/etc/init.d/lightdm start

Xorg.confファイル:

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
2
chris-sc