it-swarm-ja.com

DebianWheezyへのSkypeのインストール[AMD64]

はい、Debian Wheezy(7.4)AMD64にSkypeをインストールする方法についてのさらに別の質問です。それを行う方法について無数の同様の記事やフォーラムのスレッドを見ましたが、私にとってはそうではありません:(

これが私がすることです:

dpkg --add-architecture i386
apt-get update
wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
dpkg -i skype-install.deb

部分的にのみインストールします。

dpkg: dependency problems prevent configuration of skype:
 skype depends on libasound2 (>= 1.0.16).
 skype depends on libc6 (>= 2.3.6-6~).
 skype depends on libc6 (>= 2.7).
 skype depends on libgcc1 (>= 1:4.1.1).
 skype depends on libqt4-dbus (>= 4:4.5.3).
 skype depends on libqt4-network (>= 4:4.8.0).
 skype depends on libqt4-xml (>= 4:4.5.3).
 skype depends on libqtcore4 (>= 4:4.7.0~beta1).
 skype depends on libqtgui4 (>= 4:4.8.0).
 skype depends on libqtwebkit4 (>= 2.1.0~2011week13).
 skype depends on libstdc++6 (>= 4.6).
 skype depends on libx11-6.
 skype depends on libxext6.
 skype depends on libxss1.
 skype depends on libxv1.
 skype depends on libssl1.0.0.
 skype depends on libasound2-plugins.

dpkg: error processing skype (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils ...
Processing triggers for hicolor-icon-theme ...
Errors were encountered while processing:
 skype

apt-get -f installでこれを修正してみてください。

The following packages will be REMOVED:
  skype:i386
0 upgraded, 0 newly installed, 1 to remove and 27 not upgraded.
1 not fully installed or removed.

aptitude -f installなどを使用して、さまざまなリポジトリを試しました。何も役に立ちません。何かアイデアはありますか?それらはかなり無駄な数時間でした...

4
kK-Storm

オプションを使い果たした後-必要なすべての:i386パケットをインストールしようとする依存関係の問題を解決する-最終的にapt-getは1104パッケージを削除して新しい20:Dをインストールすることを提案します-私はこの特定の行を https://wiki.debian.org/skype

libqtwebkit4:i386をインストールできません

Apt-getが依存関係としてlibqtwebkit4:i386をインストールできない場合は、aptitudeで試してください(何をしているのかわかっている場合)

おそらくバージョンskype-debian_2.2.0.35-1_AMD64.debが必要なため(新しいバージョンにはpulseaudioに関連する問題があるため)

だから私はブラインドに行きましたwget -O skype.deb http://download.skype.com/linux/skype-debian_2.2.0.35-1_AMD64.deb && dpkg -i skype.debそしてskypeは依存関係の問題なしにインストールされました! 2.2は少し古いですが、少なくとも機能します。

3
kK-Storm

私もその問題を抱えていました。次のことがうまくいきました。重要な部分はapt-get autocleanapt-get autoremoveを実行することでした。

  • 最新のDebianバージョンをダウンロードします(すでに行ったこと)。

  • 次のコマンドを実行します。

dpkg --add-architecture i386

Sudo apt-get -f install

Sudo apt-get update

Sudo apt-get upgrade

Sudo apt-get -f install

  • これは私の問題を解決した重要な部分です。

Sudo apt-get autoclean

Sudo apt-get autoremove

  • そして最後にSkypeをインストールします:

Sudo apt-get install skypeまたは

dpkg -i skype-... .deb

ここで、skype ... .debは、skype.comからダウンロードした.debです。

1
patapouf_ai

GDebiを使用します。 dpkgコマンドと同様にコマンドラインからローカルの.debファイルをインストールできますが、依存関係を解決するためにリポジトリにアクセスできます。
パッケージgdebi(またはgdebi-coreコマンドラインユーティリティのみ)。

0
Nikita Kniazev