it-swarm-ja.com

wpa_supplicantでDebian Jessieのwifiに接続できない:ioctl [SIOCSIWENCODEEXT]:無効な引数

Ifplugdまたはwpa_supplicantを介して、USBWi-Fiで無線LANに接続できません。私のwpa_supplicant.confコンテンツ:

  ctrl_interface=/var/run/wpa_supplicant

  network={
  driver=wext
  ssid="myessid"
  scan_ssid=1
  proto=WPA
  pairwise=TKIP
  group=TKIP
  key_mgmt=WPA-PSK
  psk="mypassphrase"
 }

私が使用するコマンド:

 wpa_supplicant -iwlan0 -Dwext -cwpa_supplicant

出力:

 Successfully initialized wpa_supplicant
 ioctl[SIOCSIWENCODEEXT]: Invalid argument
 ioctl[SIOCSIWENCODEEXT]: Invalid argument

同時に、iwevent wlan出力は次のとおりです。

 Waiting for Wireless Events from interfaces...
 17:02:53.825711   wlan0    Set Mode:Managed
 17:02:53.826035   wlan0    Set ESSID:"g\xC6isQ\xFFJ\xEC)\xCD\xBA\xAB\xF2\xFB\xE3F|\xC2T\xF8\x1B\xE8\xE7\x8DvZ.c3\x9F\xC9\x9A"

また、iwpriv wlanは次のことを示しています。

wlan0     Available private ioctls :
      ndis_reset       (8BF0) : set   0       & get   0      
      power_profile    (8BF1) : set   1 int   & get   0      
      deauthenticate   (8BF3) : set   0       & get   0      
      network_type     (8BF2) : set   1 char  & get   0      
      media_stream     (8BF4) : set   1 int   & get   0      
      reload_defaults  (8BF7) : set   0       & get   0 

Ndiswrapperを使用しています。

私のデバイス:

 Bus 002 Device 002: ID 0457:0163 Silicon Integrated Systems Corp. 802.11 Wireless LAN Adapter

Ndiswrapper出力:

 sis163u : driver installed
device (0457:0163) present

Ndiswrapperは、起動時にmodprobeによってロードされます。

そして、私のiwconfig出力は:

 wlan0     IEEE 802.11g  ESSID:off/any  
      Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
      Bit Rate:54 Mb/s   Tx-Power:16 dBm   Sensitivity=0/3  
      RTS thr:off   Fragment thr:off
      Encryption key:off
      Power Management:off
      Link Quality:0  Signal level:0  Noise level:0
      Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
      Tx excessive retries:0  Invalid misc:0   Missed beacon:0

編集:私はそれを間違っていました。 -Cの代わりに-cパラメータを使用する必要がありました。しかし残念ながら、問題は本質的に同じです。

2
victim

wpa_supplicantコマンドの出力は次のように終了します。

You may have another wpa_supplicant process already running or the file was left by an unclean termination of wpa_supplicant in which case you will need to manually remove this file before starting wpa_supplicant again.

...それはかなり明白なはずです。すでにwpa_supplicantが実行されているかどうかを確認する必要があります。次の方法で行います。

pgrep wpa_supplicant

それが何らかの出力を生成する場合は、killが提供したプロセスIDをpgrepする必要があります。そうでない場合は、wpa_supplicantが作成しようとするファイルをクリーンアップする必要があります。

それでも問題が解決しない場合は、上記を行った後に出力を投稿してください(コメントとしてではなく、元の投稿で)

2
Wouter Verhelst