it-swarm-ja.com

未定義のエラー:0 OR autoload.phpをロードできません。DrushではComposer

/ usr/local/lib/drush/drushにdrushをインストールし、/ usr/local/bin/composerにcomposerをインストールしました。

Drush/usr/local/lib/drush/drushを実行しようとすると、次のようになります。

/ usr/local/lib/drush/drush:129行目:/Applications/MAMP/bin/php/php5.2.17/bin:はディレクトリ/ usr/local/lib/drush/drush:129行目:exec:/ Applications /MAMP/bin/php/php5.2.17/bin:実行できません:未定義のエラー:0 –

または次のようにします。

Autoload.phpをロードできません。 Drushは、依存関係とオートロードクラスをインストールするためにComposerを必要とします。README.mdを参照してください。

何が悪いのですか?誰かが何か提案があれば、MAMPで使用するためにdrushをインストールしたいと思います。 READMEを読み終えましたが、何も機能していないようです。

7
radishred

Drushは必要な作曲家に切り替えました。 documentation は、composerとdrushの両方をインストールする方法の詳細を提供しますが、要約すると次のようになります。

  • インストールcomposerグローバルに:

    curl -sS https://getcomposer.org/installer | php
    mv composer.phar /usr/local/bin/composer
    
  • Drushをグローバルに(ユーザーに対して)インストールします。バージョンを指定できます。

    composer global require drush/drush:6.*
    
  • composerパスを(。bashrcまたはに)パスに追加します。 zshrcまたはその他):

    export PATH="$HOME/.composer/vendor/bin:$PATH"
    
8
T0xicCode

Linuxでcomposerを使用して、drushをグローバルにインストールするために使用した手順は次のとおりです(〜/ .composer/vendor/binにrootとしてログインしないため、まったく意味がありません)。

  1. ルートとしてログイン
  2. インストールcomposer必要な場合。参照してください http://getcomposer.org/doc/00-intro.md#system-requirements
  3. composer global require drush/drush:6. *またはcomposer global require drush/drush:dev-master
  4. cd〜/ .composer
  5. composer config --global bin-dir/usr/local/bin
  6. composer config --global vendor-dir/usr/local/share
  7. 作曲家のインストール
  8. cp -r vendor// usr/local/share/drush/drush /
  9. cd/usr/local/share/drush/drush
  10. 作曲家のインストール

これで、パスに/ usr/local/binが含まれているすべてのユーザーがdrushを実行できます。

セキュリティ上の注意:特定のグループ内の承認されたユーザーのみがdrushを実行できるように、chownおよびchmod/usr/local/bin/drushする必要がある場合があります。

注:5行目と6行目では、ファイル〜/ .composer/config.jsonを作成しています。行10は、不要な/ usr/local/share/drush/drush/vendor/drushフォルダーを削除(はい、削除)するために必要です。

3
uberhacker

「OSX + drush + mamp」のようにググったことがありますか... http://kerasai.com/blog/2013/07/30/easy-way-make-drush-work-mamp

MAMPでのdrushの主な問題は、drushがMAMPにパッケージされているPHPを使用せず、通常PHPがDrupalの要件を満たすように構成されていないことです。 OSXに同梱されているPHPを再構成してDrupalの要件を満たすことができますが、MAMPのPHPを使用するのが賢明ではないでしょうか?これを行うには、次の行を追加します。 〜/ .profileに、必要に応じて調整します。

alias drush='DRUSH_PHP=/Applications/MAMP/bin/php/php5.4.10/bin/php /usr/local/drush/drush'
2
tenken