it-swarm-ja.com

Drushを実行するには、より高いbootstrapレベルが必要です

私が実行したときにこのエラーを引き起こしている可能性があるものについて何か考えがありますか?

drush si geoslate --db-url='mysql://root:[email protected]/geoslate' --site-name=Geoslate

コマンドsite-installを実行するには、より高いbootstrapレベルが必要です。このコマンドを実行するには、より機能的なDrupal環境から呼び出す必要があります。
drushコマンド 'si vimn_geoslate'を実行できませんでした。
A Drupalインストールディレクトリが見つかりませんでした

16
Andrew Welch

この特定のエラーは、drushが読み取るべきsettings.phpファイルを見つけられず、それ自体を「ブートストラップ」できない場合に発生します。

drupalインストールのdrupalディレクトリ(ドキュメントルート)にcdして、settings.phpファイルを読み取る必要があります。

18
4life

そのエラーの場合:Drushを実行するには、より高いbootstrap=レベルが必要です。

端末に書き込みます:mysql

あなたが何かを見た場合:

不明なコマンド「mysql」

次に、問題はmysqlから発生します。そのため、drushコマンドが機能しません。

BrewでMySqlをインストールします: https://brew.sh

Brew install mysql
2
Karim Rachadi

私はこの問題に遭遇し、受け入れられた答えを試しましたが、うまくいきませんでした。この質問がGoogleの結果で高く評価されたので、私の状況で他の人を助けることを期待して私のソリューションを提供しています。

私の場合、mysql-clientパッケージがインストールされていません。 apt-get install mysql-client Drushを修正しました。

Drupal開発マシンにmysql-clientパッケージをインストールしなかったのはなぜですか?私はWindowsで開発していて [〜#〜] wsl [〜#〜]を使用しています Drushの目的。

1
almcnicoll

一部のモジュールをインストールして有効にしたいとき、このエラーが発生しました。私のサイトのsettings.phpファイルの_'Host' => 'localhost'_の行を'Host' => php_sapi_name() == 'cli' ? '127.0.0.1' : 'localhost'に変更することで、Drushを介してモジュールをインストールできます。

1