it-swarm-ja.com

16.04でEclipseが機能しない

Eclipseは14.04で何と同じように機能していた。 16.04のクリーンインストールを行い、Eclipseをインストールしました。しかし、Javaプログラムは一度だけ実行され、その後、削除して再インストールする前の後続の試行でハングします。最初はCDTも必要だったので、多くのことを試しました。今のところ、Eclipseに関連するすべてのものを削除して、新規インストールを行います(すべての構成と依存関係を削除します)。 Eclipseインストーラーを使用してEclipseをインストールしましたが、Eclipseアイコンイメージも表示されないことに注意してください(デフォルトのubuntu?が表示されます)。

59
Ankur Lathwal

16.04とEclipse Marsでも同じことがありました。私はそれが凍結したと思ったが、実際には非常に非常にゆっくりと動いていた。問題は、16.04に同梱されているGTK + 3のバージョンです。幸いなことに、解決策は非常に簡単です。ターミナルを開き、export SWT_GTK3=0と入力してから、ターミナルからEclipseを起動します。それが機能する場合、より永続的な修正は、Eclipse.ini以下の2行が表示されるを配置することです。

--launcher.GTK_version
2

行の前:

--launcher.appendVmargs

バグは bug 1552764 でUbuntuに報告されています

114
NickT

ヒントをありがとう。

Javaの必要なバージョンを以下から変更する必要がありました。

-Dosgi.requiredJavaVersion=1.7

-Dosgi.requiredJavaVersion=1.8

この行も削除します:

-XX:MaxPermSize=256m

ハッピーコーディング!

5
staplr

Eclipse.desktopを次のように編集します。

Exec=env SWT_GTK3=0 Eclipse
3
Haozhe Xie

私の推奨事項は、WebページからEclipse Marsをインストールすることです。 http://www.Eclipse.org/downloads/index-developer.php?release=mars

ただし、最初にJava8をインストールする必要があります(Eclipse Marsはそのバージョンでは動作しないため、Java9ではありません)。 Ubuntuでは、これを次の方法で実行できます。Sudo apt-get install openjdk-8-jre openjdk-8-jdk

そして..そして他のJavaバージョンがある場合、次のコマンドでJava8を選択する必要があります:Sudo update-alternatives --config Java

ほら!それは私のために働いた! :)

1
Gonzalo

どうやらこれは既知の bug Ubuntu 16.04でのことです。これはEclipseだけでなく、他のいくつかのアプリケーションにも影響します。

修正がリリースされる前に、ここで簡単な修正を行います。ターミナルを開いて入力する

$ initctl restart unity-panel-service

これにより、現在のセッションのメニューが表示されます。ただし、マシンを再起動する場合は、これを再度行うことができます。

0

コマンドライン(ターミナル)からアプリケーションを起動することにより、プログラムが起動に失敗する理由に関する詳細情報を取得できる場合があります。例(Eclipseがパスにあると仮定します。そうでない場合は、Eclipseがインストール/アンパックされたフォルダーから開始します):

[email protected]:~$ Eclipse
Unrecognized VM option 'MaxPermSize=256m'
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

この場合、線のように見えます

-XX:MaxPermSize=256m

ファイルEclipse.iniに問題があります。その行を削除して(最初にEclipse.iniファイルのバックアップを作成して)、プログラムを再起動してください。

上記のソリューションは、15.10から16.04にアップグレードされたマシンでEclipse Version: Mars.2 Release (4.5.2)で機能しました

0
Ronny Andersson

libjavascriptcoregtk-4.0またはWTFCrashでエラーが発生する場合は、libwebkitgtk-3.0-0をインストールしてください。

Sudo apt install libwebkitgtk-3.0-0

0
wisbucky