it-swarm-ja.com

EclipseがLunaからMarsへのアップグレードの試みを検出しない

EclipseのインストールをLunaからMarsにアップグレードしようとしていますが、利用可能なソフトウェアサイトのリストにEclipse Marsリポジトリを追加したにもかかわらず、Eclipseが更新を見つけられないという問題があります。更新チェックを実行するたびに、「更新が見つかりません」というメッセージが表示されるだけです。アップグレードを機能させるにはどうすればよいですか?

Available Software Sites

7
DaveTheMinion

私はこの問題を解決しなかったので、新しいバージョンのEclipseをダウンロードして、すべてを再インストールしました。そうすることで、以前は無視していた、過去にEclipseで発生した他の問題が解決されたようです。

1
DaveTheMinion
  1. 次のソースを使用可能なソフトウェアリスト(Window > Preferences > Install/Update > Available Software Sites > Add)に追加します:
  2. 古いソースを削除します( http://download.Eclipse.org/releases/luna/ および http://download.Eclipse.org/Eclipse/updates/4.4 ) 。

  3. Help > Install New Softwareに移動し、Work with:ドロップダウンから http://download.Eclipse.org/Eclipse/updates/4.5 を選択します。 The Eclipse Project Updatesという名前にする必要があります。

  4. Eclipse Java Development Tools > Eclipse Java Development ToolsEclipse Platform > Eclipse Platformにチェックマークを付けてから、Nextをクリックします。次の画像を参照してください(グレー表示されません-私はすでにアップグレードしています)。

Eclipse Upgrade

  1. 次の画面で、古いプラグインを削除するように求められる場合があります(依存関係が壊れている/欠落しているため)。

  2. Eclipseを再起動するように求められます。再起動すると、EclipseMarsのスプラッシュ画面が表示されます。