it-swarm-ja.com

TestNGはEclipse 2019-03と互換性がありません

Eclipse 2019-03にTesgNGをインストールしようとすると、Eclipse 2019-03と互換性がないとしてTestNGメッセージが表示されました。

TestNG incompatible for Eclipse 2019-03

3
user1043280

このEclipseをインストールしてみてください。私はあなたと私が同じ問題を抱えていた別のバージョンをインストールしました。しかし、EclipseではIDE for Java開発者向けTestNGが利用可能です。さらにヘルプが必要な場合は、このリンクも試してください: https:// www .toolsqa.com/Selenium-webdriver/install-testng /

Eclipse IDE for Java開発者向け

2
Grazi Silva

私はEclipseをアップグレードせずにこの問題を解決しました。

移動: https://testng.org/doc/download.html

そして、Eclipseマーケットからプラグインをダウンロードしてみてください。 https://beust.com/Eclipse

これが機能しない場合は、s> http://beust.com/Eclipse を削除してみてください。

1

現在、これらのバージョンのEclipseのみがサポートされています
Eclipseバージョン: 酸素(4.7)、ネオン(4.6)、火星(4.5)、ルナ(4.4)、ケプラー(4.3)、ジュノ(4.2、3.8)、ジュノの前(<= 4.1)、フォトン(4.8)、2018-09( 4.9)
Javaバージョン: Java EclipseプラグインのTestNGを実行するには、1.7 +が必要です。
更新がある場合は、次のリンクにアクセスしてください。 https://marketplace.Eclipse.org/content/testng-Eclipse

1
Krishna Singh