it-swarm-ja.com

Ubuntuにemacs 24.3をインストールする方法は?

Ubuntuを使用するのはこれが初めてであり、プログラムをどのようにインストールすべきかわかりません。あるディレクトリをcdで使用してから./configureを実行しましたが、動作しません!

36
anita

Damien CassouのPPA の使用を検討してください。

このPPAを追加するには:

Sudo add-apt-repository ppa:cassou/emacs
Sudo apt-get update

Emacs-snapshotの場合:

Sudo apt-get install emacs-snapshot-el emacs-snapshot-gtk emacs-snapshot

Or、emacs24(つまり、24.3、安定):

Sudo apt-get install emacs24 emacs24-el emacs24-common-non-dfsg

更新

Damien CassouのPPA で述べたように、リポジトリはこれ以上維持されず(現在はEmacs 24.3を備えています)、 buntu Elisp PPA を使用することをお勧めします。

したがって、これを使用してPPAを追加します。

Sudo add-apt-repository ppa:ubuntu-elisp/ppa
Sudo apt-get update
Sudo apt-get install emacs-snapshot emacs-snapshot-el

参照: Emacsガイド

35
hayd

24.3でのみ使用可能な特定の機能が必要な場合を除き、Ubuntuで既にビルド、テスト、パッケージ化されているバージョンのemacsを使用する方が、Ubuntuでビルドするよりもおそらく優れているでしょう。

ターミナル内:

Sudo apt-get install emacs
23
Paul

ソースからビルドするのは悪くありません。必要なバージョンを選択することができ、Emacsはさらに高速に動作し、問題は依存関係を見つけてインストールすることです。

Emacs 24.5 w /依存関係をインストールするコマンド:

Sudo apt-get update
Sudo apt-get install build-essential
Sudo apt-get build-dep emacs24
cd ~/Downloads
wget "http://gnu.mirrors.hoobly.com/gnu/emacs/emacs-24.5.tar.gz"
tar xvzf emacs-24.*.tar.gz
cd emacs-24.*
./configure --without-x
make
Sudo make install

できた.

3
Delfin

私はUbuntu 14 LTS-x64と次のコマンドworks for meを使用しています;

Sudo apt-get install emacs24

ForDaily Emacsbuild installation;

Sudo apt-add-repository ppa:ubuntu-elisp/ppa
Sudo apt-get update
Sudo apt-get install emacs-snapshot emacs-snapshot-el

参照: Emacsガイド

2
gihanchanuka

簡単な答え:Ubuntu 16以前に戻ります。

Ubuntu 18をインストールしました。emacs25.2.2の壊れたスクロールバーに夢中になりました。ここでの他のソリューションは機能しませんでした(aptは署名なしリポジトリを許可しなくなりました)。次のように、debianパッケージからemacs 23.4をインストールできました。

https://packages.debian.org/wheezy/all/emacs23-common/download

dpkg -i emacs23-common_23.4+1-4+deb7u1_all.deb

https://packages.debian.org/wheezy/emacs23-bin-common

dpkg -i emacs23-bin-common_23.4+1-4+deb7u1_AMD64.deb

https://packages.debian.org/wheezy/AMD64/libgif4/download

dpkg -i  libgif4_4.1.6-10+deb7u1_AMD64.deb

https://packages.debian.org/wheezy/AMD64/xaw3dg/download

dpkg -i xaw3dg_1.5+E-18.2_AMD64.deb

https://packages.debian.org/wheezy/AMD64/libpng12-0/download

dpkg -i libpng12-0_1.2.49-1+deb7u2_AMD64.deb

https://packages.debian.org/wheezy/AMD64/libtiff4/download

dpkg -i libtiff4_3.9.6-11+deb7u10_AMD64.deb

https://packages.debian.org/wheezy/emacs23-lucid

dpkg -i emacs23-lucid_23.4+1-4+deb7u1_AMD64.deb

この手法はemacs 24.3でも機能すると思います。

しかし、Ubuntu 18は必要ありません。gnomeボリュームはすべてを破壊します。数回の再起動後、すべてのローカルボリュームマウントが失敗し(ハードウェアが明らかにmemfsでローカルマウントスクリプトに到達しているにもかかわらず、/ boot/efiでさえ)、毎回手動で緊急シェルにマウントする必要があります。 emacs 24に付属するUbuntu 16に戻ります。

0
personal_cloud