it-swarm-ja.com

RHEL6はGoogleChromeでサポートされなくなりました。回避方法はありますか?

RHEL6でGoogle Chromeを更新しようとすると、エラーが発生します。

[[email protected] ~]$ Sudo yum update
[Sudo] password for alexus: 
Loaded plugins: refresh-packagekit, security
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package google-chrome-beta.x86_64 0:27.0.1453.93-200836 will be updated
---> Package google-chrome-beta.x86_64 0:28.0.1500.20-201172 will be an update
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.15)(64bit) for package: google-chrome-beta-28.0.1500.20-201172.x86_64
--> Finished Dependency Resolution
Error: Package: google-chrome-beta-28.0.1500.20-201172.x86_64 (google-chrome)
           Requires: libstdc++.so.6(GLIBCXX_3.4.15)(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[[email protected] ~]$ cat /etc/redhat-release 
Scientific Linux release 6.4 (Carbon)
[[email protected] ~]$ uname -a
Linux wcmisdlin02.uftmasterad.org 2.6.32-358.6.2.el6.x86_64 #1 SMP Thu May 16 11:21:38 CDT 2013 x86_64 x86_64 x86_64 GNU/Linux
[[email protected] ~]$ 

次の記事を見つけました:

RHEL6でv28に移行するためにできることはありますか? (その他はRHEL7を待ちます)?

2
alexus

こちらのスクリプトもお試しください:

64ビットGoogleをインストールする方法Chrome 64ビットRHEL/CentOS 6または7に28 +

最新のChromeに加えて、ダウンロードしたFedora 15RPMから抽出されたさまざまなライブラリをダウンロード/インストールします。64ビットCentOS6.4システムでChrome 28を実行できます。正常に。

2
user237862

この投稿で説明されているように、古いバージョンをインストールしてみることができます: http://georgeinenglish.com/solved-google-chrome-no-longer-installs-on-centos-6-4/

1
jggonz

私の理解では、これはgccバージョンの問題/要件です。chromeが設定されています。gccをバージョン4.7.0にアップグレードしてみてください。rhel6マシン以来、個人的には試していません。はプロジェクトの要件に関係するバージョンでロックされていますが、機能するようになったら、この現在のプロジェクトが終了したら更新できるようにしたいと思います。

0
ckcin