it-swarm-ja.com

IIS 6?でASP.Netバージョンを選択するオプションはありません。

Windows Server 200364ビット版を実行しています。新しいWCFサービスを起動して実行するために、.Net 4Frameworkをインストールしました。ただし、ASP.Netフレームワークのバージョンを選択するためのオプションはIIS 6のどこにもありません。つまり右クリック>プロパティ Webサイトには、ASP.Netタブがあり、そこからv2またはv4を選択できるはずです。

なぜ彼らがそこにいないのか、そしてどうすれば彼らを出現させることができるのか誰かが知っていますか?とりあえず、Website> Properties> Home Directory> Configurationに移動し、.svc拡張子を変更する必要がありました。代わりにv4.0.30319を使用します。これで、すべてが私のWCFサービスで機能していますが、他のすべての拡張機能はv2に設定されています。

タブを取得するにはどうすればよいですか? 23のWebサイトのいずれにも表示されません。

3
djdd87

aspnet_regiis.exeの.NET4バージョンはコマンドラインから機能しますか?コマンドラインオプションを使用して、設定する特定のWebアプリケーションを指定できます(コマンドライン構文を表示するには、aspnet_regiis -?を使用します)。

1
Richard

.net4サイトを実行する新しいアプリケーションプールを作成する必要があります。

編集:あなたが話しているそのasp.netタブは何もしません。一部の構成設定を変更することはできますが、.net4に切り替えることはできません。複数の.net4 Webサイトを実行していて、asp.netタブに常に最初のエントリ.net2.0。*が表示されます。

0
ZippyV

インターネット上のさまざまなWebサイトから:

1)ASP.Net4.0が無効になっていることを確認します。

cscript iisExt.vbs /ListFile

2).Net 4のエントリの左側に0がある場合は、それを有効にする必要があります

3).Net4拡張機能を有効にする

cscript iisExt.vbs /EnFile C:\WINDOWS\Microsoft.NET\Framework64\v4.0.30319\aspnet_isapi.dll

4)最初のコマンドを実行すると、.Net4の横に0ではなく1が表示されます。

これで、.NET Frameworkv4アプリが実行されます。

0
Wayne