it-swarm-ja.com

Linux mint17.3でソフトウェアを更新またはインストールできません

これはスローするエラーです:

W: Failed to fetch http://packages.domain.com/dists/trusty/InRelease  

W: Failed to fetch http://packages.domain.com/dists/trusty/Release.gpg  Unable to connect to packages.domain.com:http:

W: Some index files failed to download. They have been ignored, or old ones used instead.  

Fontconfigとdpkgにもエラーがあり、このエラーが時々発生します:

E: fontconfig: subprocess installed post-installation script returned error exit status 1

これを解決するのに助けが必要です。

お時間を割いていただきありがとうございます。

2
Jayanthan

参照しているリンクは古くなっています(実際には配布のバグでした)。 「ソフトウェアソース」で無効にします(またはコメントアウトします/etc/apt/sources.list)および更新を更新します。

ファイルの内容も確認してください。
/etc/apt/sources.list.d/official-package-repositories.list

少なくとも次のものが含まれている必要があります。

deb http://packages.linuxmint.com rosa main upstream import 
deb http://extra.linuxmint.com rosa main
deb http://cosmos.cites.illinois.edu/pub/ubuntu trusty main restricted universe multiverse
deb http://cosmos.cites.illinois.edu/pub/ubuntu trusty-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ trusty-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ trusty partner

そして、このファイルで壊れたパッケージをコメントアウトします。

壊れたリンクを削除するには-左下隅のメニューボタンをクリックし、検索フィールドに「ソフトウェアソース」と入力してクリックし、すべてのソフトウェアソースで壊れたリポジトリがないか確認します。

また、パッケージが次のことを確認してください。

libcurl3-gnutls
apt-transport-https

インストールされています。

一部のリポジトリはhttpsに切り替わり、これらのパッケージがインストールされていない場合は、
Failed to fetch再びエラー。

fontconfigに関しては、パッケージを再インストールしてみてください。

 Sudo apt-get install --reinstall --purge fontconfig-config
0
Alex