it-swarm-ja.com

.NET3.5をインストールするには.NET3.5が必要なのはなぜですか?

編集:コメント/回答する前に、私がすでに試したことを読んでください。ありがとう。

私は完全にばかげた問題を見つけました。ラップトップにWin10があります。 .NET 4.5がインストールされていますが、3.5はインストールされていません。 3.5を使用するゲームを実行したい(3.5を使用しないと実行されません)。オンラインまたはオフラインの.NET3.5インストーラーを実行すると、.NET3.5をインストールするには.NET3.5が必要であると表示されます。

Ridiculous error is ridiculous

これは非常に苛立たしいことです。手動でインストールする方法はありますか?


私が試したこと:

  • .NET 3.5オンラインインストーラー(2Mb)の実行
  • .NET 3.5オフラインインストーラー(237Mb)の実行
  • リストされている方法3に従ってdism.exeを使用する ここThe referenced Assembly is not installed on your system.と表示されます)
  • .NET検証ツールの実行。
  • Windowsを更新しています(失敗し、何も変更されていないと表示されます)
  • インストーラーのトラブルシューティング(Incompatible programと表示されますが、.NET 4.5がインストールされているため間違っています)
  • .NET 2.0のインストール(どうやら私も.NET 3.5が必要です)

これらのどれも機能しません!何か案は?

2
Pyroglyph

これを修正するために私が見つけた唯一の方法は、Windows 10インストールメディアを再ダウンロードし、Win10を最初からインストールすることです。

0
Pyroglyph

.NET 3.5は、Windows10のインストールにすでに含まれているはずです。Windowsの機能で有効にできます。 このリンク の手順に従ってください

0
Addison F.

.NET3.5をWindows10にインストールするには、Windowsの機能を使用し、特定のソースインストールファイル(つまり、インストール元のDVDまたはUSB)を使用する必要があります。私はほとんどの場合このコマンドを使用します(昇格したコマンドプロンプトから):

dism /online /enable-feature /featurename:netfx3 /all /source:d:\sources\sxs

代用d:\ DVDまたはUSBドライブ用で、準備は万端です。

0
DarkMoon