it-swarm-ja.com

UbuntuにAndroid Studioをインストールできない

Ubuntu Gnome 14.04を使用しています。Java8がインストールされています(JDKとJREの両方)。

私がAndroid Studioをインストールしていたとき、すべてがうまくいったが、メッセージが表示されました:

Mksdcard SDKツールを実行できません

Android Studioを正しくインストールするにはどうすればよいですか、それともどのように修正すればよいですか?

160

あなたが64ビットUbuntuを実行していると仮定して、 "問題 82711 "に対して提案された修正はあなたの問題を解決するはずです。

Sudo apt-get install lib32z1 lib32ncurses5 lib32bz2-1.0 lib32stdc++6

更新:Ubuntu 15.10と16.04の場合Sudo apt-get install lib32z1 lib32ncurses5 lib32stdc++6

272
Rajesh

@ワルソンは正しいです。 lib32stdc++6だけをインストールすることで問題は解決しました。

次回の使用のために、私は回答エリアに@warsongsコメントを書き換えます。

Sudo apt-get install lib32stdc++6

更新:

Ubuntu 15.04、15.10、16.04 LTSとDebian 8の場合

82
Sayem

Fedora(Fedora 23/24用にテスト済み)の場合

dnf install compat-libstdc++-296 compat-libstdc++-33 glibc libgcc nss-softokn-freebl libstdc++ ncurses-libs zlib-devel.i686 ncurses-devel.i686 ant
11
Timo Bähr

私はその質問がUBUNTUに関するものであることを理解していますが、私はDebian Jessie 64bitで同様の問題を抱えていたので、warsongsの提案もそれに有効でした。
studio.shを実行するとAndroid Studioが起動しますが、Android SDKを設定しようとするとエラーが発生しました
Unable to run mksdcard SDK tool
いつ試したか
Sudo apt-get install lib32z1 lib32ncurses5 lib32bz2-1.0 lib32stdc++6
エラーが発生しました
E: Package 'lib32bz2-1.0' has no installation candidate
だからワルソンの提案を受けて、lib32stdc ++ 6だけをインストールしようとしました。
Sudo apt-get install lib32stdc++6
これでAndroid SDKをAndroid Studioに追加できました。

4
drlolly

このページをチェックしてください

開発用マシンで64ビットディストリビューションを実行している場合は、まず追加のパッケージをインストールする必要があります。 Ubuntu 13.10(Saucy Salamander)以上の場合は、libncurses5:i386を使用してlibstdc++6:i386zlib1g:i386、およびapt-getパッケージをインストールします。

Sudo dpkg --add-architecture i386
Sudo apt-get update
Sudo apt-get install libncurses5:i386 libstdc++6:i386 zlib1g:i386
3
sudoz

Ubuntu 12.10ではこれらのオプションはどれも私にとっては役に立ちませんでした(そう、アップグレードする必要があります)。しかし、私は簡単な解決策を見つけました。ここからソースをダウンロードしてください。 https://github.com/miracle2k/Android-platform_sdk/blob/master/emulator/mksdcard/mksdcard.c 。それから、単に "gcc mksdcard.c -o mksdcard"でコンパイルしてください。 SDKツールサブフォルダー内のmksdcardをバックアップし、新しくコンパイルしたものと置き換えます。 Android StudioはSDKに満足しています。

2
mjancola

問題はmksdcardが正しくインストールされていないことが原因で発生します。

64ビットを実行している場合は、mksdcardの問題を解決するためにこれを行ってください。

    Sudo dpkg --add-architecture AMD64
    Sudo apt-get update
    Sudo apt-get install libncurses5:AMD64 libstdc++6:AMD64 zlib1g:AMD64

と32ビット:

    Sudo dpkg --add-architecture i386
    Sudo apt-get update
    Sudo apt-get install libncurses5:i386 libstdc++6:i386 zlib1g:i386

SDK 6.0では、エラーメッセージは異なりますが、同じことを意味します。

    Unable to run mksdcard
2
Kyler Chin

Linux Mintの場合

Sudo apt-get install lib32z1 lib32ncurses5 libbz2-1.0 lib32stdc++6
0
Bit-Man

Sudo apt-get install lib32z1 lib32ncurses5 libbz2-1.0 lib32stdc++6を実行したときに、 "The following packages have unmet dependencies: lib32stdc++6 : Depends: lib32gcc1 (>= 1:4.1.1)"のようなメッセージが表示された場合。

あなたはこのようなことをすることができます:

0
anhnv

この問題はあなたの64ビットOSが順番にいくつかの32ビットバイナリをインストールしようとしているAndroid SDKをインストールしようとしたときに発生し、したがって互換性の問題です。

追加の端末を開いてタイプする

Sudo apt-get install lib32z1 lib32ncurses5 lib32bz2-1.0 lib32stdc++6 

必要なすべてのバイナリをインストールするのに役立ちます。その後、Android SDKのインストールプロセスを再開してください。

0
Selvaperumal