it-swarm-ja.com

それを好む間それでもjQueryの複数のバージョンを使用する WP 好き

プラグインの中に2つのJSプラグインがあります。一方はjQuery 1.7.1を使用し、もう一方は1.9.1を使用します。

それぞれに異なるバージョンを使用させる必要があります。これが今のところ物事の様子です。

プラグインphpファイル:

wp_register_script('jq-1.9.1-js', 'https://ajax.googleapis.com/ajax/libs/jquery/1.9.1/jquery.min.js');
wp_enqueue_script('jq-1.9.1-js');
wp_register_script('jq-1.7.1-js', 'https://ajax.googleapis.com/ajax/libs/jquery/1.7.1/jquery.min.js');
wp_enqueue_script('jq-1.7.1-js');

プラグインJSファイル:

    var $j = jQuery.noConflict();

    $j(document).ready(function() {
    // plugin 1
    $j('.someClass').plugin1({
        // options
    });
    // plugin 2
    $j('.someClass').plugin2({
        // options
    });
}

私はかなりGoogleを検索し、複数のバージョンに対する解決策を見ましたが、WPにスクリプトを含めるための適切な方法(registerおよびenqueueの使用)を考慮に入れていませんでした。

スクリプトをWPのように呼び出しながら、2つのJSプラグインに対して2つのバージョンのjQueryを使用する方法を教えてください。

ありがとう

2
corre

私は最新のjQueryバージョン(WordPressがデフォルトでロードする)を使用し、最新のjQueryバージョンと互換性のないJSプラグインファイルを修正することによって非互換性の問題を処理するのが私にはより良いことがわかりました。

注:この解決策を選んだ理由は、ほとんどの場合、JSプラグインの新しいjQueryバージョンとの非互換性は、コード内で廃止予定のメソッドまたは関数を使用し、通常その呼び出しを既存の関数への呼び出しに置き換えるためです。この問題を解決し、冗長なjQueryスクリプトを含めることを免除します。

さらに、将来プラグインが更新される場合、新しいバージョンではおそらく最新のjQueryバージョンがサポートされるため、現在使用しているものを問題なく更新できます。

0
corre