it-swarm-ja.com

デフォルトのjquery UIライブラリを新しいバージョンでオーバーライドする

Jquery ui coreの最新版は私のサイトにあるバグを修正します。問題は、Wordpressには以前のバージョンが付属していることです。

デフォルトのjquery UIコアをオーバーライドするにはどうすればよいですか?私が見つけた一つの解決策はwordpressのincludeフォルダのscript-loader.phpファイルを編集することですが、私がしなければならない場合を除き、私はWordPressコアに触れたくありません。

下記は私が避けたいと思っていた中核的な変更です。

$scripts->add( 'jquery-ui-core', '/wp-content/themes/themefolder/jquery.ui.core.min.js', array('jquery'), '1.9.2', 1 );
1
Julian

次のコードをあなたのテーマのfunctions.phpファイルに追加すると、デフォルトのjquery ui coreが削除され、提供されている最新のjquery ui coreファイルがテーマから追加されます。

function my_scripts_method() {  
 if(!is_admin()){     
    wp_deregister_script( 'jquery-ui-core' );
wp_enqueue_script('jquery-ui-core', get_stylesheet_directory_uri().'/jquery.ui.core.min.js', array('jquery'), '1.9.2', 1 );
}
}     
add_action('wp_enqueue_scripts', 'my_scripts_method');

それがあなたのために働くかどうか教えてくださいまたは私はあなたに別の解決策を提供します...

4
Vinod Dalvi