it-swarm-ja.com

WP adminをjQuery 1.5に更新する価値はありますか?

私はjQuery 1.5がちょうど リリースされた ことを読んだ。

バージョン1.4.2をこの新しいリリースに置き換えることは、純粋なパフォーマンスの点で価値があると思いますか(現在のテーマではjQueryをあまり使用していないため、管理者側で)。副作用や互換性の問題はありますか?

1
Drake

さて、パフォーマンスは リリースポスト はこう言います:

今回のリリースでは、よく使われるいくつかのトラバーサルメソッド、.children()、.prev()、および.next()のパフォーマンスも向上させることができました。私たちが見ているスピードアップはかなりのものです(ブラウザによっては、何倍も速くなる可能性があります)。

一方で、管理者側でjQueryを置き換えることはめったに得策ではありません。なぜなら、それは連結されたスクリプトの束にマージされつつあり、対処するのが面倒だからです。

あなたが管理者の中でかなりのJSパフォーマンスの問題に苦しんでいない限り、私の個人的な意見はそれはトラブルに値するものではないということです。

PS WP 3.1は、新しい1.4.4 jQueryバージョンを持っているでしょう、彼らが最終リリースまでにそれを1.5まで持っていくことを気にするかどうか知りません。

更新

WordPress 3.0.5はjQuery 1.5と同時にリリースされました。残念ながら、1.5には後方互換性のない変更がいくつかあり、それらは管理者の多くの分野を壊しているように見えます。タイミングはぎこちないし、それはそれが私たちだったように見えます。そうではありませんでした。

JQuery 1.4.4で凍結しているWordPress 3.1でもこれについて私たちができることは何もありません。

Andrew Nacin

そのため、説明されているt31osの問題は間違いなくjQuery 1.5が原因で発生しており、現時点ではadmin領域での使用は絶対にお勧めできません。

3
Rarst

Rarstの回答へのコメントとしてhakreがリンクしているチケットは3.2がjQuery 1.5を含むべきであることを示すので、あなたは3.2まで待つことができます。

あるいは、管理者に1.5をロードする方法を見つけました。

これは連結があってもなくても機能します(問題をさらに注意してください)。

add_action( 'admin_init', 'try_jquery_version');
function try_jquery_version() {
    global $wp_scripts;
    if( !is_object( $wp_scripts ) )
        return;
    if( !isset( $wp_scripts->registered['jquery'] ) )
        return;
    $wp_scripts->registered['jquery']->src = 'https://ajax.googleapis.com/ajax/libs/jquery/1.5.0/jquery.js';
    $wp_scripts->registered['jquery']->ver = '1.5';
}

副作用がいくつかありますが、それがキャッシングの結果なのか、それとも他のjQueryスクリプトも新しいjQueryバージョン(つまり、ui-core)に合わせて更新する必要があるのか​​、それとも単純にできないのかわかりません。現時点ではWordPressで正しく動作します。

既知の問題:

  • ダッシュボードウィジェットは読み込まれないようです。
  • 未定義の変数などに関連するFirefoxのコンソールに表示されるさまざまなエラー(私はこれらが起こる理由を知るのに十分なJSについては知りません)

私は上記に私が見る追加の問題を追加します。

今のところ、私は1.5をテストし続け、私がどうやって着手するかを見るつもりです、それが違いを生むかどうか確かめることは面白いはずです(少し速いように思えます、しかしそれは私がそれを想像することができる)。

更新日:2011年2月2日
WPチェンジセットを見てきたので、jqueryをWordPressに統合するために行われる特別なことは何も言えない限り、jqueryは単に必要に応じて更新されるように見えます。

私は現在、私が経験した問題は新しいバージョンのjqueryの変更による自然な結果であるか、または以前のコピーのキャッシュされたバージョンを提供している(またはuiをjquery toでインライン更新する必要がある)と仮定しています。私は他のことを成し遂げる必要があったので、私は今のところ1.4(WPに含まれているものは何でも)に切り替えていますが、とにかく私の観察には特に興味がありませんでした。それらを聞いてください。

1
t31os