it-swarm-ja.com

14.04でカーネルを構築するために必要なQtパッケージをインストールする方法は?

Ubuntu 14.04 64ビットでカーネルをコンパイルするので、必要なパッケージのインストールから始めます。

Sudo apt-get install build-essential bin86 kernel-package libqt3-headers libqt3-mt-dev wget libncurses5 libncurses5-dev qt4-dev-tools libqt4-dev

libqt3-headersおよびlibqt3-mt-devパッケージを除くすべてがインストールされます。ターミナルで入手したパッケージの場合:

E: Unable to locate package libqt3-headers
E: Unable to locate package libqt3-mt-dev

周りを見てみると、Ubuntu 14.04リポジトリにはそれらのパッケージがないようです。

何をすべきか考えていますか?

3
mixerowsky

TL; DR:すでにインストールしたものに基づいて、インストールするだけで pkg-config Install pkg-config そしてあなたは行ってもいいはずです。

make xconfigを実行してカーネルの内容を設定する場合は、Qtを使用してカーネルを構築します。 (これは最も簡単な方法の1つであるため、どの方法を使用しますか。)

少なくともリモートの最近のカーネルでは、Qt 3の代わりにQt 4を使用できます。インストールする必要があります。

  • libqt4-dev Install libqt4-dev 、xconfigユーティリティはQt4に対してリンクできます、and
  • pkg-config Install pkg-config なので、make xconfiglibqt4-devによってインストールされたQt4ヘッダーを自動的に検出して使用できます。

これらのパッケージは、ソフトウェアセンターから、または次のものを使用してインストールできます。

Sudo apt-get update
Sudo apt-get install libqt4-dev pkg-config

make xconfigの詳細については、 this answer to カーネルを再コンパイルする簡単な方法は何ですか? を参照してください。)

必要ありませんbothQt3およびQt4ヘッダー:正しくインストールされ、make xconfigで識別されるようにシステムが設定されている場合(- pkg-configはこれを容易にする1つの方法です )、もう1つは必要ありません。

ちなみに、そうすることに害はありませんが、明示的にqt4-dev-toolsをインストールする必要があるのはnotです。 libqt4-devdeclares 依存関係としてのlibqt4-dev-binqt4-qmakeなどの他の必要なQt4関連パッケージ。これらも自動的にインストールされます。また、make menuconfigmake xconfigの非グラフィカルな代替)を実行する場合にのみ、ncursesパッケージが必要です。

あなたの場合、あなたはすでに libqt4-dev Install libqt4-dev インストール済みなので、インストールできるのは pkg-config Install pkg-config

3
Eliah Kagan
Sudo apt-get install -y build-essential kernel-package libncurses5-dev bzip2 bin86 qt4-dev-tools  wget libncurses5 git-core nautilus-open-terminal

新しいLinux> 13.10を使用しているため

0
bangdes

これらのパッケージはQtバージョン3に属し、現在のバージョンが5.3であるため廃止されています。これらはリポジトリに含まれなくなりました。

とにかくこれらのパッケージが必要になる理由はわかりません。

以前にシステムにカーネルを構築したことがない場合、正常に構築する前にいくつかのパッケージが必要です。これらは次の方法でインストールできます。

Sudo apt-get build-dep linux-image-$(uname -r)

ソース: https://wiki.ubuntu.com/Kernel/BuildYourOwnKernel

0
Cornelius