it-swarm-ja.com

カーネルをダウングレードする方法は?

カーネルを2.6.32-358.6.2.el6.centos.plus.x86_64から2.6.32-220.el6.x86_64にダウングレードする必要があります

次のエラーが発生するため、Yum/rpmを使用して古いバージョンをインストールできません

[email protected] kernels]# rpm -i --ignoreos kernel-2.6.32-220.el6.x86_64.rpm 
warning: kernel-2.6.32-220.el6.x86_64.rpm: Header V4 DSA/SHA1 Signature, key ID  
192a7d7d: NOKEY
package kernel-2.6.32-279.el6.x86_64 (which is newer than kernel-2.6.32-220.el6.x86_64) is already installed
package kernel-2.6.32-358.6.1.el6.centos.plus.x86_64 (which is newer than kernel-2.6.32-220.el6.x86_64) is already installed
package kernel-2.6.32-358.6.2.el6.centos.plus.x86_64 (which is newer than kernel-2.6.32-220.el6.x86_64) is already installed

現在実行中のカーネルを削除できないので、どうすればよいですか?

Yum検索では、この古いバージョンにさえ到達しないため、Webからrpmを取得する必要がありました。

どんな助けでも大歓迎です。

1
JATMON

rpm -ivh <kernel.rpm> --oldpackageはcentosで仕事をします

これでカーネルがインストールされます。grubエントリが適切であることを確認してから、再起動してこのカーネルを起動できます。

2
JATMON

実際、ダウングレードはカーネルでは機能しません。正しいコマンドはlocalinstallです:

#yum localinstall ./kernel....rpm

5つ以上のカーネルがある場合、yumは最も古いものを削除します。

3
al3xxx