it-swarm-ja.com

ソフトウェアマネージャーから古いバージョンのgccコンパイラをインストールし、プレーンな「gcc」コマンドで使用する方法は?

Matlab mexcompileの問題に苦労しています。特定の古いバージョンのgccコンパイラ4.4.6が必要です。しかし、マネージャーには4.4バージョンしかありません。どうすれば4.4.6として指定できますか?それとも可能ですか?

次に、gccコマンドとして実行する必要があります。現在、私のgccコマンドは4.7.2バージョンを実行しています。 gccコマンドを切り替えて、Mintマシンで古いバージョンを実行するにはどうすればよいですか。コンパイラのみをインストールしてもMatlabでは機能せず、プレーンなgccコマンドを呼び出しているためです。

4
erogol

パッケージgcc-4.4を他のバージョンのgccと一緒にインストールするだけです。次のステップは、デフォルトのgccをこの特定のバージョンに変更することです。最もエレガントで簡単な方法は、update-alternativesを使用することです。これはすべて このStackoverflow.comの回答 で説明されています。

5
gertvdijk