it-swarm-ja.com

バイナリファイルを実行できません。 exec形式エラー

最近、Node.jsベースのブラウザー Breach について聞いたことがあります。 ここ の指示に従ってインストールしましたが、次のエラーが発生しました:

breach-v0.3.22-alpha.6-linux-x64/__ AUTO_UPDATE_BUNDLE __/exo_browser/exo_browser:cannot execute binary file:Exec format error

グーグルで検索したところ、32ビットのUbuntuインストールに64ビットのパッケージをインストールしようとしていることが原因であることがわかりました。同じ32ビットパッケージを見つけようとしましたが、うまくいきませんでした。ブラウザは、64ビットパケットでのみ利用できます(私の知る限り)。

だから、私の質問は:

どういうわけかそれを32ビットOSにインストールすること、または32ビットOSで64ビットアプリケーションを実行できる利用可能なプログラムがある場合、それをインストールすることは可能ですか?.

私はぐるぐる回っていて、助けがありませんでした。誰か助けてもらえますか?

Ubuntu 14.04(32ビット)を使用しています。

4
user2689020

32ビットOSを使用している場合は、32ビットアプリケーションが必要です。 64ビットアプリケーションを実行する唯一の方法は、64ビットOSで実行することです。ところで、64ビットOSの下で32ビットアプリケーションを実行することは可能です。

だからここでの提案:

  1. 32ビットパッケージを見つけて使用する

  2. ソースを見つけ、32ビットシステムの完全な再コンパイルを行い、インストールして使用します。

  3. システムを64ビットUbuntuにアップグレードします。

2
mdpc

32ビットのカーネルで64ビットの実行可能ファイルを実行することはできません。

2ビットLinuxで64ビットの実行可能ファイルを実行できますか?

そのスレッドのポスターは、エミュレーターの使用(つまり、32ビットアーキテクチャのエミュレーション)を提案しています。

これは少し役に立たないように聞こえるかもしれませんが、64ビットカーネルで32ビットソフトウェアを実行する方が簡単なので、32(つまり、ハードウェア関連)を特に必要としない限り、通常は64ビットインストールを使用するのが最善です。

1
cadge