it-swarm-ja.com

要求されたバージョン1.5.0と互換性のあるパッケージ「ECM」の構成ファイルが見つかりませんでした

リポジトリから「ECMConfig.cmake」をダウンロードしようとしましたが、ターミナルからエラーが表示されます:"質問のタイトル+次の構成ファイルは考慮されましたが、受け入れられませんでした:ECMConfig.cmake:バージョンは不明です Googleで検索しようとしましたが、何も見つかりませんでした。次のコマンドを使用して、ソース「kdeフレームワーク」からコンパイルしたいと思います。

cmake .. -DCMAKE_INSTALL_PREFIX=/home/john/QtProjects/KDEStuff/frameworkintegration/build/ 
         -DCMAKE_BUILD_TYPE=debugfull -DCMAKE_PREFIX_PATH=/home/john/Downloads/

PS:
"/ home/john/Downloads /"-ここに* .cmakeがあります。

35
pushandpop

extra-cmake-modules KDEプロジェクトの複製、コンパイル、インストールを試みます。

git clone git://anongit.kde.org/extra-cmake-modules
cd extra-cmake-modules
mkdir build && cd build    
cmake ..
make && Sudo make install
48
Diego Lopez

私の場合、単にextra-cmake-modulesパッケージをインストールする必要がありました。

17
f3xy