it-swarm-ja.com

ArchLinuxへのVMwareのインストールに関する問題

VMwareをインストールしようとしていますが、「VMwareを実行する前に、いくつかのモジュールをコンパイルして、実行中のカーネルにロードする必要があります」と表示されたら、[インストール]をクリックしてパスワードを入力すると、エラーが発生します。

Unable to stop services.

See log file /tmp/vmware-root/vmware-28896.log for details.

nanoを使用して解決策を探してみましたが、ファイルが存在しませんでした。vmwareを実行しているときにフォルダーを調べましたが、このためのログファイルは作成されませんでした。何をする必要があるのか​​わかりません。非常にあいまいです。私はオンラインとフォーラムを見ましたが、私の問題に近いものを持っている人を見つけることができません

私のカーネルところで

4.2.3-1-Arch

VMwareパッチを使用して修正しようとしましたが、-vも使用しましたが、実行中にエラーが発生しました

==> Patching VMware Workstation Pro v12.0.0 for kernel 4.2.3-1-Arch..
-> [vmci]
-> Extracting archives..
-> Patching..
patching file vmci-only/linux/driver.c
patching file vmci-only/linux/vmciKernelIf.c
patching file vmci-only/shared/vm_device_version.h
-> Recreating archives..
==> Installing modules..
sh: /home/hashfastr/vmware: Is a directory
Unable to stop services
==> error: Unable to build. See:
* /tmp/vmware-root/vmware-1360.log
* /tmp/vmware-root/vmware-17013.log
* /tmp/vmware-root/vmware-17148.log
* /tmp/vmware-root/vmware-18919.log
* /tmp/vmware-root/vmware-18925.log
* /tmp/vmware-root/vmware-18931.log
* /tmp/vmware-root/vmware-19162.log
* /tmp/vmware-root/vmware-19492.log
* /tmp/vmware-root/vmware-19769.log
* /tmp/vmware-root/vmware-20058.log
* /tmp/vmware-root/vmware-20336.log
* /tmp/vmware-root/vmware-2069.log
* /tmp/vmware-root/vmware-2075.log
* /tmp/vmware-root/vmware-2081.log
* /tmp/vmware-root/vmware-21046.log
* /tmp/vmware-root/vmware-21323.log
* /tmp/vmware-root/vmware-21405.log
* /tmp/vmware-root/vmware-21998.log
1
Bob_the_rhino

カーネルは常にVMWareでサポートされているバージョンよりも新しいため、VMWareにArchでモジュールをビルドさせるのは常に注意が必要です。

AURから vmware-patch をインストールすることをお勧めします。

vmware-patchは、インストール時にvmware-modulesにパッチを適用してビルドします。

その後、VMWareまたはカーネルをアップグレードするたびに再実行する必要があります。

Sudo vmware-patch

VMWareサービスを自動的に停止/開始できるはずですが、同じ障害が発生した場合は、少なくともターミナルウィンドウに表示され、よりよく表示されます。

1
ams