it-swarm-ja.com

CentOS6.6でのglibcのアップグレード

サーバーがglibc-2.12.x.を使用している場合、特定のパッケージをインストールするとエラーが発生します。依存関係が見つかりませんglibc-2.14以上が必要です。yum install glibc*を使用しようとすると、サーバーはすでに最新のものでインストールされていると表示されますバージョン。

yumupdaterを使用してglibc-2.14以上にアップグレードするにはどうすればよいですか?また、centos6.6を7に更新せずにglibc-2.14を使用することに問題はありますか。

ありがとう、Vivek。

4
NINJA

実行yum info glibcインストールされているglibcのバージョンと、使用可能なバージョンを確認します。

glibc-2.14は私のCentOS6.8では利用できないので、yumを使用してアップグレードすることはできないと思います。

新しいバージョンのオープンソースソフトウェア(通常のユーザーのみ)をインストールする必要がある場合は、Linuxbrewすべてをホームディレクトリにインストールすることを強くお勧めします。

お役に立てれば

1
Ask and Learn