it-swarm-ja.com

debhelperをアップグレードできません

私はラップトップでUbuntu16.04を実行していますが、通常のプロセスはほぼ毎日アップグレードすることです。今日、「Sudo apt list --upgradable」と入力すると、次のメッセージが表示されます。

❯Sudo apt list --upgradable
 Listing... Done
 debhelper/xenial,xenial 10.2.2ubuntu1~ubuntu16.04.1 all [upgradable from:9.20160115ubuntu3]
 N: There is 1 additional version. Please use the '-a' switch to see it

だから私は推奨通りにやった、私は入力します:

❯Sudo dh -a
 dh: No compatibility level specified in debian/compat
 dh: This package will soon FTBFS; time to fix it!
 dh: Compatibility levels before 4 are no longer supported (level 1 requested)

それから私は走った:

Sudo apt upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

なぜdhをアップグレードしないのですか?、それを修正するにはどうすればよいですか?

前もって感謝します。

ほとんどどこでも複雑な解決策を探した後、私はもっとシンプルで透明なものを試すことにしました:適性を使う

Sudo aptitude update

壊れたパッケージがいくつか見つかりました。

Sudo aptitude upgrade

壊れたパッケージを修復するかどうかを尋ねられたので、「y」と入力すると、壊れたパッケージがすべて修正され始めました。

このソリューションがあなたにも役立つことを願っています。

残念ながらまだコメントできませんが、同じ問題に遭遇しました。実際に実行する場合:

Sudo apt upgrade debhelper

それはそれを示すエラーを返します

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 debhelper : Depends: dh-autoreconf (>= 12~) but 11 is to be installed
             Depends: dh-strip-nondeterminism (>= 0.028~) but 0.015-1 is to be installed
             Depends: dpkg-dev (>= 1.18.23ubuntu3) but 1.18.4ubuntu1.3 is to be installed
E: Broken packages

少なくとも私はKDENeon LTS(16.04に基づく)で実行しているので、エラーはパッケージマネージャーによってのみ修正できると思います。

1
matt3o