it-swarm-ja.com

Java EEを使用しているかどうかを知る方法は?

今日、私はJava EEをインストールしました。.shファイルを 公式のOracleソース からダウンロードし、Sudo sh filename.shコマンドを使用して実行しました。

ただし、LinuxMintマシンにはいくつかのバージョンのJavaがあり、コマンドSudo update-alternatives --config Javaを使用してアクセスします。

There are 2 choices for the alternative Java (providing /usr/bin/Java).

  Selection    Path                                            Priority   Status
------------------------------------------------------------
  0            /usr/lib/jvm/Java-7-Oracle/jre/bin/Java          1074      auto mode
  1            /usr/lib/jvm/Java-7-openjdk-AMD64/jre/bin/Java   1071      manual mode
* 2            /usr/lib/jvm/Java-7-Oracle/jre/bin/Java          1074      manual mode

Press enter to keep the current choice[*], or type selection number: 

そして、Java -versionコマンドを使用すると、次のようになります。

$ Java -version
Java version "1.7.0_45"
Java(TM) SE Runtime Environment (build 1.7.0_45-b18)
Java HotSpot(TM) 64-Bit Server VM (build 24.45-b08, mixed mode)

これらすべての出力を読んでも、「JavaEE」バージョンについて言及しているものは見つかりません。だから私は私が明確にする必要があるいくつかの質問があります:

  1. デフォルトとして使用しているかどうかを本当に知るにはどうすればよいですか?
  2. デフォルトで使用していない場合、どうすればよいですか?
  3. 上記の手順が不可能な場合、Eclipse IDEを使用するように設定するにはどうすればよいですか?

よろしくお願いします、ペドロ。

4
Flame_Phoenix

Java EEは、事実上、通常はサーバー内のJava SE上で実行される(.jarファイル内の)エンタープライズライブラリの集まりです。したがって、Java -version自体は「SE」とだけ言います。また、実行中のサーバー用に調整された「サーバーVM」とも表示されます。ただし、64ビットLinuxではすべてのデフォルトのVMです。 (起動時にVMの選択を構成またはオーバーライドします。VMは実行中のアプリの種類を「認識」しないため、選択しません。)

リンクしたJavaEEはGlassfishサーバーをインストールします。その特定のバンドルには独自のJDKがあります。実際には古いバンドルです。したがって、どこに置いても、glassfish3/jdk7ディレクトリに移動してbin/Java -versionを実行すると、Java version "1.7.0_10"ではなく_45が報告されます。 「コア」ランタイムはjdk7/jre/lib/rt.jarにあることに注意してください

EEJARはglassfish3/glassfish/modulesにあります。メインのものは「javax」で始まる名前を持っているので、find . -name 'javax*.jar'で見ることができます

Glassfishでアプリを実行すると、クラスパスマジックを実行して、それらのJARを使用できるようにする必要があります。 IDEを使用している場合は、コードをコンパイルできるように、IDEも同様のことを行う必要があります。手動でプログラミングしている場合は、自分でプログラミングする必要があります。

したがって、あなたの質問に答えるために、SEも使用せずにEEを「使用」することはできません。そして、EEを使用するための唯一の実際の要件は、JARをクラスパスに置くことです。 Eclipseには、「Glassfishをポイント」して、すべてを検出させる方法が必要です。

この特定のケースでは、古い_10JDKも削除する必要があります。次に、既存の_45glassfish3/jdk7の代わりに配置します。または、PATH、Java_HOME、glassfish3/glassfish/config/asenv.confなどに必要な変更を加えて、実行します。古いJDKを誤って実行したくない。

6
Ken

LinuxではWindowsOSとは少し異なります。Ubuntu18.0.4で環境をセットアップする方法を記述します。 JavaでJSPまたは動的Webページの開発を開始するには、4つのツールが必要です。

1。 JavaSDK
2。 Glassfish
3。 ApacheTomcatサーバー
4。 Eclipse IDE


1.Oracle Javaをインストールします
LinuxプラットフォームopenjdkまたはOracle-jdkで使用するJava)については、多くの議論があります。両者の違いは知りたくありませんが、Oracleを使用することをお勧めします。 -不明な理由によるjdk:)

インストール手順リポジトリを追加

Sudo add-apt-repository ppa:webupd8team/Java
Sudo apt-get update

インストールJava using

Sudo apt-get install Oracle-Java8-installer




2.Glassfishをインストールします
[。このライブラリをインストールすると、パッケージjavax。の下にクラスを簡単にインポートできます。

Glassfishのインストール:

Sudo apt-get install glassfish-javaee




3.Tomcatサーバー
訪問 https://Tomcat.Apache.org/download-70.cgi そして最新の安定したTomcatサーバーをダウンロードします。ステップバイステップの構成については、このリンクにアクセスしてください

https://www.javatpoint.com/how-to-configure-Tomcat-server-in-Eclipse-ide




4.Eclispe
eclispe公式サイトにアクセスし、Eclipse forJava-EEをダウンロードしてください

https://www.Eclipse.org/downloads/packages/Eclipse-ide-Java-ee-developers/oxygen3a

これは、Eclispeを使用して動的Webプロジェクトを開始するための巧妙に作成されたチュートリアルです。 https://www.javatpoint.com/creating-jsp-in-Eclipse-ide

1

HotSpotはOracleのJVMであるため、知っておく必要があるのはHotSpotだけです。したがって、今後、$PATHからJavaコマンドを使用するすべてのプログラムは、OracleのJavaを使用します。また、javacupdate alternativesで調整する必要があります。

  1. 一部のプログラムには、Javaを検索する他の方法があるため、創造性を発揮してください。
  2. アプリケーションに依存
  3. Eclipseを使用していないのでごめんなさい
1
Arne