it-swarm-ja.com

LinuxでD-LinkDWA-182 Rev.D1を実行する方法

最近、D-Link DWA-182リビジョンD1を購入しました。ラベルには「H/WVer。:D1 F/WVer.:4.00」と記載されています。残念ながら、Linuxカーネルには必要なドライバーが付属していません。どうすれば無線LANスティックを機能させることができますか?

2
Max Görner

D-Linkは、そのWebサイトでLinux4.9以前と互換性のあるドライバーを提供しています。

https://support.dlink.com/ProductInfo.aspx?m=DWA-182

そこにRev.Dのドライバーをダウンロードできます。アーカイブには、Linuxカーネルモジュールのコードを含む「driver」という名前のサブフォルダーがあります。必要な依存関係があれば、makeを呼び出してモジュールをコンパイルできます。便宜上、ドライバーと簡単なビルド手順のみを含むGithubリポジトリを作成しました。

https://github.com/MaxG87/DWA-182_Rev-D1

残念ながら、ドライバーはカーネル4.16と互換性がありません。 4.9から4.16の間のカーネルは試しませんでした。

更新:

Linux 4.16を使用している場合、すべてのコンパイルの問題にパッチを適用しました。前述のGitHubリポジトリのマスターブランチを使用して、動作するカーネルモジュールを構築できます。広範なテストは実行しませんでしたが、Linux4.16でDWA-182を使用してこの更新プログラムをアップロードしています。パッチを使用したすべてのオープンソースプロジェクトに感謝​​します。

4
Max Görner

このハードウェアは、次のようにRTL8812BUチップセットを使用します。 https://wikidevi.com/wiki/D-Link_DWA-182_rev_D1

このチップセットについては、次のコマンドを試してください。

Sudo apt update
Sudo apt install -y git
git clone https://github.com/EntropicEffect/rtl8822bu.git
cd rtl8822bu
make
Sudo make install
Sudo modprobe 88x2bu
1
user3704898

カーネル4.15.0-60のUbtunu 18.04の更新

https://github.com/MaxG87/DWA-182_Rev-D1 失敗

しかし https://github.com/cilynx/rtl88x2BU_WiFi_linux_v5.3.1_27678.20180430_COEX20180427-5959

魅力のように機能します

0
linpete