it-swarm-ja.com

Linux MintにGCC / G ++バージョン4.9をインストールする

私は常に最新のものを使いたいと思っています。特に、それがgcc、g ++で、最近c ++標準に改訂があった場合は特にそうです。

G ++-4.9をインストールできるようにするために、システムに追加する必要があるppa(Ubuntu組織のもの)を忘れてしまいました。

このプロセスを完了する方法を思い出させてください、ありがとう。

8
user3728501

Ubuntu 14.04(およびその派生物)のすべてのアップストリーム開発ツールは、ppa:ubuntu-toolchain-r/testから入手できます。

次のようにアクティブ化します。

Sudo add-apt-repository ppa:ubuntu-toolchain-r/test
Sudo apt-get update
Sudo apt-get install g++-4.9

ソース: https://wiki.ubuntu.com/ToolChain#PPA_packages

お役に立てれば!

11
Alex Reinking

自動化スクリプトが古いライブラリを指すシンボリックリンク "g ++"を変更して、それが必要な場合は新しいスクリプトを使用する必要がある場合もあります。 g ++-4.8を指すシンボリックリンクg ++を見つけます。これはおそらく/ usr/binにあります。削除して、バージョン4.9を指す新しいポインティングを作成します。

Sudo ln -s g++-4.9 g++
0