it-swarm-ja.com

MySQL8.0をアンインストールして5.7をインストールします

mysqlバージョンを8.0から5.7にダウングレードしようとしています。 MySQL 8.0を正常にアンインストールできましたが、5.7をインストールしようとすると、次のエラーが発生します。

Error: Package: mysql-community-server-5.7.27-1.el7.x86_64 (mysql57-community)
           Requires: mysql-community-common(x86-64) = 5.7.27-1.el7
           Installed: mysql-community-common-8.0.17-1.el7.x86_64 (@mysql80-community)
               mysql-community-common(x86-64) = 8.0.17-1.el7

次のコマンドを実行しました。

1)MySQLリポジトリを追加します。

rpm -ivh https://dev.mysql.com/get/mysql80-community-release-el7-1.noarch.rpm

2)MySQL5.7をインストールします。

yum -y install mysql-community-server --disablerepo=mysql80-community --enablerepo=mysql57-community

この点でどんな助けでも非常に役に立ちます。

1
Vivek H B

エラーはかなりはっきりしていると思います。 mysql-community-serverにはmysql-community-commonまったく同じバージョン番号のパッケージが必要です。したがって、アンインストールする必要もありますmysql-community-common-8.0.17-1.el7.x86_64

rpm -e mysql-community-common-8.0.17-1.el7.x86_64

または

zypper remove mysql-community-common-8.0.17-1.el7.x86_64

5.7バージョンをインストールできるように。

1
Chris Maes