it-swarm-ja.com

openSUSE 13.2カーネルの安定バージョン(4.1)へのアップグレード

OpenSUSE 13.2を使用していて、カーネルを最後の安定バージョンにアップグレードしようとしています。

リポジトリにhttp://download.opensuse.org/repositories/Kernel:/stable/standard/を追加し、Sudo zypper dup -r kernel_stableコマンドでアップグレードしてみました。
次のエラーが発生します:

Checking for file ......................................[done]
(1/3) Installing: kernel-devel-4.1.4-1.1.ga37e14f ..............................................................................[done]
(2/3) Installing: kernel-desktop-4.1.4-1.1.ga37e14f ............................................................................[done]
Additional rpm output:
Creating initrd: /boot/initrd-4.1.4-1.ga37e14f-desktop
Executing: /usr/bin/dracut --logfile /var/log/YaST2/mkinitrd.log --force /boot/initrd-4.1.4-1.ga37e14f-desktop 4.1.4-1.ga37e14f-desktop
*** Including module: bash ***
*** Including module: warpclock ***
*** Including module: i18n ***
*** Including module: network ***
Failed to install module ipv6
Failed to install module xennet
*** Including module: ifcfg ***
*** Including module: drm ***
*** Including module: plymouth ***
*** Including module: kernel-modules ***
Failed to install module sd_mod
Failed to install module hid_generic
1
mlibre

エラーは、OpenSUSEおよびRHELで使用されるinitramfsインフラストラクチャであるdracutから発生しました。一部のモジュールは、カーネルですでに使用可能であるため、initramfsにインストールできません。

これは、任意のプレーンテキストエディタを使用してカーネルの構成ファイル(つまり、/boot/config-4.1.4-1.ga37e14f-desktopファイル)を調べることで確認できます。カーネルに組み込まれているドライバーの値はyです。たとえば、ipv6の場合、CONFIG_IPV6=yの線に沿って何かが表示されるはずです。同じ原則が、dracutがinitramfsにインストールできなかった他のすべてのモジュールにも当てはまります。

結論として、インストールはうまくいきました。新しいカーネルで起動してみてください。

1
Larssend