it-swarm-ja.com

VLCの満たされていない依存関係

2つのパーティションに分割されるようにUbuntuをインストールしました(/および/homeとしてマウントされます)

Sudo apt-get install vlcを実行した後、near fresh install of buntu 16.04.2 LTS(Xenial Xerus)で次のエラーが発生します。

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
 vlc : Depends: libgles1-mesa (>= 7.8.1) but it is not going to be installed or
                libgles1
E: Unable to correct problems, you have held broken packages.

問題を修正する最も簡単な方法は何ですか?

Sudo apt-get cleanを再度実行する前に、Sudo apt-get updateSudo apt-get dist-upgrade、およびSudo apt-get install vlcを試しました。

また、libgles1-mesaSudo apt-get install libgles1-mesaと一緒にインストールしようとしましたが、エラーが返されます(リンクされた質問を参照)

これが可能かどうかはわかりませんが、コアLinuxファイルを元のインストーラー(まだ持っている)から/パーティションに再インストールして、libgles1-mesaが表示されることを期待できますか?
(ファイルやアプリケーションの設定を失うことなく)

注:私は https://askubuntu.com/q/889356/ のOPと同じ問題を抱えているようですが、Ubuntuのバージョンは異なります。

3
LifeLongLearner

私の場合、vlcパッケージを含むソースリストに2つのリポジトリがありました。

  1. 公式vlcリポジトリ ppa:videolan/stable-毎日;
  2. buntuユニバースレポ

最初のリポジトリには新しいvlcパッケージがあったので、Sudo apt-get install vlc最初のソースからインストールされました。

解決策は、最初のソースからすべてのパッケージを削除し、このソースリストを削除することでした

Sudo apt-get update
Sudo apt-get install ppa-purge
Sudo ppa-purge ppa:videolan/stable-daily

次に、UbuntuUniverseリポジトリからvlcをインストールします

Sudo apt-get update
Sudo apt-get install vlc
1
sempasha

私のように満たされていない依存関係に問題があった場合は、PPAを追加する解決策がありますffmpeg-4すると、正しくインストールできるようになります。

Sudo add-apt-repository ppa:jonathonf/ffmpeg-4
Sudo add-apt-repository ppa:jonathonf/vlc-3
Sudo apt-get update
Sudo apt-get install vlc

ソース: https://launchpad.net/~jonathonf/+archive/ubuntu/vlc-

0
Blackcoat77