it-swarm-ja.com

--with-pgsqlを使用してPHPを再コンパイルする方法

Postgresql、php、ApacheをAmazon LinuxAMIにインストールしました。 phpPgAdminを使用したいのですが、「あなたのPHPインストールはPostgreSQLをサポートしていません。-with-pgsqlconfigureを使用してPHPオプション。 "!Amazon Linux AMI用に再コンパイルするにはどうすればよいですか?提案してください。ありがとうございます。

2

OSがRPMベース(Fedora/CentOS)で、インストールした場合[〜#〜] php [〜#〜] from [〜#〜] rpm [〜#〜]、次のコマンドを実行します。

yum install php-pgsql

OSがDebianベース(buntu/Debian)の場合は、次のコマンドを実行します。

apt-get install php5-pgsql

変更を有効にするには、Apacheサービスを再起動することを忘れないでください。

5
RoseHosting