it-swarm-ja.com

Yum repo with python 2.6 on Centos7

CentOS7マシンでNodejs4を実行する必要があります。このマシンでのインターネットアクセスは制限されており、基本的にヒットできるのはYumリポジトリ(新しいリポジトリを追加できます))のみです。
Nodejs 4はEPELでも使用できないため、プライベートYumリポジトリを使用しており、Nodejs 4をRPMでラップしています。このRPMを作成しておらず、変更できませんそれ。
問題は-前述のNodejs4RPMはPython 2.6に間接的に依存しています(依存関係の依存性にはこのバージョンのPythonが必要なので間接的です)。今Python 2.6はCentos7 yumリポジトリでは利用できません(EPELでも利用できません)。利用できるバージョンは2.7.5と3.4.3のみです。したがって、前述のNodejs 4RPMのインストールは失敗します。

Error: Package: nodejs4-runtime-4.4.2-22.el6.x86_64 (nodejs4)
       Requires: python(abi) = 2.6
       Installed: python-2.7.5-34.el7.x86_64 (@bertinet-base-7)
           python(abi) = 2.7
           python(abi) = 2.7
       Available: python34-3.4.3-4.el7.x86_64 (epel)
           python(abi) = 3.4

私が言ったように、私はYumリポジトリを除いてインターネットにアクセスできません。理由を聞かないでください、それは私の決定ではありません、私はこれを変更することはできません。
このマシンにはNodejs4が必要です。
Centos7の信頼できるYumリポジトリはありますか?Nodejs4またはPython 2.6?ありがとうございます。

1

nodejs4-runtime-4.4.2-22。el6。x86_64-EL7へのEL6のパッケージのインストールは機能しません。

たとえば here からel7のパッケージを取得しますが、これは他のソースのnodejsと競合する可能性があります。

指示 ノードサイトは十分に明確です。

とにかく、これは https://stackoverflow.com/questions/32561962/install-nodejs-4-on-redhat の複製のように見えます

1
Martian