it-swarm-ja.com

githubからgitリポジトリを複製できません

OS X 10.9.2へのアップデート以降、github.comからgitリポジトリのクローンを作成できません

Git cloneコマンドを実行すると、次のエラーが発生します。

git clone https://github.com/davedelong/DDMathParser.git
Cloning into 'DDMathParser'...
fatal: unable to access 'https://github.com/davedelong/DDMathParser.git/': SSL certificate problem: Invalid certificate chain

どのリポジトリを使用してもかまいません。 Githubデスクトップクライアントでも試してみました。

そこで、Safariを介してgithub.comからSSL証明書を確認し、ssl-certが無効であるという情報を得ました。

これが私の問題のスクリーンショットです: https://dl.dropboxusercontent.com/u/215017/github_problem.png

何か案は? SSL証明書は壊れていますか?

30
patrickS

キーチェーンをチェックして問題を修正しました(アプリケーション->ユーティリティ-> Keychain Access.app)

ロギングキーチェーンに独自のDigicert証明書があることを知りました。壊れたようです。私はそれを削除しました、そしてこの後すべてがうまくいきます。

これで https://github.com のURLバーに灰色のボタンではなく緑の「ボタン」が表示されます。

13
patrickS

最近(2014年7月)に同様の問題が発生し、OS X(10.9.4)で、「DigiCert High Assurance EV Root CA」証明書が期限切れになっていることがわかりました(ただし、期限切れになっていないものもありました)。

  1. キーチェーンアクセスを開く
  2. 「DigiCert」の証明書を検索
  3. [表示]メニュー> [期限切れの証明書を表示]

「DigiCert High Assurance EV Root CA」という名前の証明書が2つ見つかりました。1つは2031年11月に有効期限が切れ、もう1つは2014年7月(数日前)に期限が切れます。期限切れの証明書を削除すると、問題が解決しました。

お役に立てれば。

41
craigb

OSXのキーチェーンに移動し、「Digicert High Assurance EV Root CA-1」を探して削除します。次に、SafariからGithubに再度アクセスします。

その後、どんなgit操作も試してみてください。うまくいくはずです。

それが役に立てば幸い。

6
frandevel

EDIT:@ craigbの答えは同じソリューションです 。修正方法に関する公式ブログの投稿へのリンクとスクリーンショットがあるので、ここに私の回答は残しておきます。


突然、OS X MavericksでMacのGitHubを使用してラップトップと仕事用のコンピューターで、以下のエラーが発生し始めました…

ここに私がクローンのために得たエラーがあります:

警告:テンプレートが見つかりません/Applications/GitHub.app/Contents/Resources/git/templates fatal:ca n't access ' https://github.com/mhulse/xxxxxx.git/ ':SSL証明書の問題:無効な証明書チェーン(128)

…そして、ここに私が同期のために得るエラーがあります:

致命的:「 https://github.com/mhulse/xxxxxx.git/ 」にアクセスできません:SSL証明書の問題:無効な証明書チェーン(128)

長い話、私はちょうどを見つけました この説明と修正を含むこの投稿

問題の有効期限が切れた証明書は、「DigiCert High Assurance EV Root CA」[2014年7月26日の有効期限]証明書です。この一時的な中間証明書は、古いデバイスの互換性チェーンの一部として何年も前に使用されていました。

...

OS Xユーザーは、キーチェーンアクセスを使用してログインキーストアから証明書を削除することで問題を解決できます。

ここに4ステップの修正があります:

キーチェーンアクセスで[表示]-> [期限切れの証明書を表示]に移動し、「DigiCert High」を検索して、2014年7月26日に期限が切れたDigiCert高保証EVルートCAを見つけます。この証明書を削除して、キーチェーンアクセスを閉じます。

fix keychain access

これで問題が解決しました!

4
mhulse

私はこれについて言及すべきだと思いました:TLS-1.2暗号化機能(以前のデフォルトはTLS 1.0)を使用するために、一部のLinuxボックスのcurl、wget、opensslを更新する必要がありました。 Macbookを起動し、「git clone」でもエラーが発生しました。ただし、SSL/TLSは問題ありません。 Gitによると「致命的:アクセスできません」:SSL証明書の問題:証明書チェーンが無効です。上記のすべてを試して、システムのキーチェーンなどから期限切れの証明書を削除しましたが、それでもgit clone試行からのエラーメッセージです。すべてをチェックする実際の演習を行った。最後に、MacOS keychain.app prgmで、2015証明書と2017証明書の両方がnotと表示されていることに気付きました。

Macbookシステムの日付が「2015年2月」に設定されていることがわかります(現在の日付は2020年2月20日です!)ラップトップの日付をリセットすると、「git clone」と「git pull」は正常に機能しました。 (日付をクリックし、右上の画面で、[日付/時刻の設定を開く]を選択し、ボックスをオンにしてマシンの日付を自動的に更新するように設定します。2017年またはそれ以降に有効期限が切れた自己署名証明書がありました。開発者アカウントに関連して、Appleから何かを取得するために日付を戻した可能性があります。これはばかげた間違いです。着陸前に着陸装置が停止していることを必ず確認してください。

0
gemesyscanada