it-swarm-ja.com

Mac OS X 10.6、Xcode 4、PowerPC Cコンパイラ?

PowerPC用にCコードをクロスコンパイルしようとすると、次のエラーが発生します。

llvm-gcc-4.2: error trying to exec '/usr/bin/../llvm-gcc-4.2/bin/powerpc-Apple-darwin10-llvm-gcc-4.2': execvp: No such file or directory

不足しているコンパイラをインストールする最良の方法は何ですか?

1
Andrew J. Brehm

Xcode4にはPPCツールは含まれていませんが、少しの作業でXcode 3インストールから移行できます。方法の詳細が記載されたサイトがありましたが、見つかりません。本当にPPC Xcode3を実行することをお勧めします。

また、あなたの状況はわかりませんが、本当に必要な場合を除いて、PPCサポートから離れることを強くお勧めします。私の意見ですが。

1
Justin Mrkva

XcodeLegacy も、古いOSXコンパイラとSDKを最新バージョンのOSX/macOSにインストールします。

このツールは、ダウンロードする必要のあるXcodeパッケージを通知し、XcodeディストリビューションからコンパイラーとSDKを抽出してインストールします。

0

見てください ここ。

さらに、これを実行します(必要に応じてパスを編集します)。

cd /Developer/usr/llvm-gcc-4.2/bin
ln -s /Developer3/usr/llvm-gcc-4.2/bin/powerpc-Apple-darwin10-llvm-gcc-4.2 powerpc-Apple-darwin11-llvm-gcc-4.2
0
James Moore