it-swarm-ja.com

TLSv1.0を無効にします-ChromeのTLSv1.2で、ダウンレベルサーバーに接続します

HP iLOに接続する必要があり、エラーが発生しますSSL_ERROR_BAD_MAC_ALERT接続しようとしたとき。

解決策は、SSL v1を無効にし、v2とv3のみを許可することのようです。 ChromeまたはMacのFirefoxでそれを行うにはどうすればよいですか?オンラインで見つけたすべてのガイドはWindows用であるか、どこにも通じていません。

2
cclloyd

ほとんどの場所では、新しいファームウェアがない限り、iLOやその他の帯域外管理システムを更新することはありません。これにより、3つまたは4つの古いバージョンのJava以前のブラウザ、および有効期限が切れた証明書が必要になるなど、楽しいことが起こります。

更新されたファームウェアがある場合、それはより新しいブラウザとSSLをサポートするかもしれませんが、私は息を止めません。

別の方法は、このためだけに古いブラウザを入手することです。このSecurity.SEの投稿によると、 Firefox 33 PortableはWindowsで動作します 。 Java et al。が必要な場合は、ささいな苦痛になります。

古い(または新しい)ブラウザを現在のバージョンと一緒に実行することもできますが、これがMacでどのように機能するかはわかりません。基本的に、SSLv3を無効にしていないブラウザ、または現在のブラウザと一緒に有効にできるブラウザが必要です。

個人的には、VMで構成されたフルインストールを実行したいのですが、 古いバージョンはここにあります 。構成して動作させ、更新を無効にします。ただし、これはテストしていませんが、少しの作業で Firefoxバージョンを並べて 実行することもできます。どうやらこれには、dmgから.appをコピーして名前を変更し(クールなトリック!)、そのバージョンを使用してプロファイルを明示的に作成し、そのバージョンへのリンクを修正することが含まれます。まだ試していません。

VMオプションは、ブラウザ以外のJavaバージョンおよびその他の前提条件を使用して環境全体を構築できるため、より適切に聞こえますが、マイレージは異なる場合があります。

3
Journeyman Geek