it-swarm-ja.com

ホストコンピュータをWindows 8から8.1に更新した後にVMWareワークステーションでVMnet0エラーが発生する

昨日、私は自分のコンピュータをWindows 8から8.1にアップデートした。このコンピュータ上でWindows XPを実行しているVMWare Workstation 10を使用していますが、アップデート前はネットワークへの接続に問題はありませんでした。しかし、アップデート以降、どのネットワークにも接続できなくなり、次のようなエラーが表示されます。

デバイスVMnet0上のネットワークブリッジが実行されていません。仮想マシンはホストまたはネットワーク上の他のマシンと通信できません。

仮想デバイスEthernet0に接続できませんでした

ネットワークアダプタがブリッジ接続用に設定されていて、デバイスステータスが "connected"になっていることを確認しました。

ここからどこへ行くのかはよくわからないが、いくつかの調査を行った後、他のユーザがホストコンピュータのOS(特にWindows 8ではなくOS)をアップデートするときにこのエラーが発生することを報告した。

50
wrigley06

私は(プログラムのインストール/変更からではなく、元のインストールファイルを使用して)修復しました。

修復が完了したら、ゲストシステムの電源を入れました。数分後、何もクリックせずに「ネットワーク接続の設定」ポップアップが表示され、ホームネットワークを選択し、共有したいものを尋ねられました - すべてをチェック/選択し、パスワードを入力して戻ってきました。必要に応じて、保存したホームグループそれでおしまい。私のインターネットアクセスが戻ってきました。私は4つのゲストシステムすべてに同じ手順を実行し、それらをインターネットで復元しました。

ところで、私はすでに私のホストのネットワークアダプタにVMWAREブリッジプロトコルを持っていて、私のゲストOSはそれを自動に持っていた - だから私はそこで何も調整しなかったが、それは私のインターネットの問題を修正しなかった。そこで、誰かがここで提案したように私は修理ルートをたどりました。

15
user265273

あなたはあなたのVMwareワークステーションから直接それを修正することができます。

  1. 編集メニューへ
  2. 仮想ネットワークエディタの選択
  3. [デフォルトに戻す]を選択します

数分かかりますが、その後はうまくいきます。

98
Saravana Ganesh

私が発見したのは、VMware Bridge Protocolが8.1へのアップグレード中に削除されたため、再インストールする必要があることです。

Windowsホストマシンでは、VMware Bridgeプロトコルを再インストールします。

Windows Vista/7の場合

  • スタート→コントロールパネル→ネットワークとインターネット→ネットワークのステータスとタスクの表示→アダプタ設定の変更の順​​にクリックします。
  • 任意のネットワークアダプタアイコンを右クリックして、[プロパティ]をクリックします。
  • [VMware Bridge Protocol]を選択して[アンインストール]をクリックします。
  • インストールをクリックします。
  • [サービス]を選択して[追加]をクリックします。
  • [VMware Bridge Protocol]を選択して[OK]をクリックします。

これらの指示はVMware Bridge Protocolをアンインストールするようにあなたに頼みます、しかし私の場合、Bridge Protocolはインストールするためにそこにありませんでした。しかし、それをインストールしてプロトコルボックスをチェックした後、VMでブリッジ接続を選択すると、再びインターネットに接続できました。

また、Windows内のVMware仮想ネットワークのネットワーク共有もオンにしました。

25
Hagen Finley

8.1にアップグレードした後、一番早い解決策は仮想ネットワークエディタの[デフォルトに戻す]であることがわかりました。

それが完了した後、私はVMネットワークアダプタのプロパティの下でVMware Bridge Protocolを選択することができました。

2
Jim

私はまたWindows 8から8.1にアップグレードした後に同じ問題を抱えていました、私はWorkStation 10を再インストールしてシステム修復オプションを選択することが私の問題を解決したことがわかりました。

1

Windows 2012 R2からWindows 2012に同じ問題がありました。しかし、注意してください - VM Bridge Protocolを削除しようとしましたが、それをインストールできなかったことを確認するためだけに使用しました。プロトコルを追加しようとしたときに表示されていませんでした。

しかし、修復はトリックを行ったようです。あなたは(少なくともWorkstation 10では)Edit> Virtual Network Editor ...の下で問題を見分けることができます。それは明らかにそこにありますが、設定が違うものです。

元のEXEから修復を実行するとそれが修正され、表示すると、自動ブリッジに設定されたVMNet0が再表示されました。

0
David Sterling

他の答えはどれもうまくいきませんでした。ゲストネットワークの接続を回復せずに、Workstation 8からWorkstation 10にアップグレードすることさえ試みました。

最後に、VMwareを明示的にアンインストールし、[Save configuration settings]チェックボックスをオフにしなければなりませんでした。最初から再インストールすると、ネットワーク接続は復旧しました。

0
cdonner